Support » Plugin: WP Migrate DB » WP Content not showing after import

  • This plugin has been great for me to migrate the DB of a project I am working on back and forth between my local dev machine and a live dev install, so that the other members of my team can input content before I pull it back down to my local machine to develop the theme templates… until yesterday.

    For some reason this last time I migrated the DB to my local machine, none of the content was showing properly in WordPress. Here is a link to a screenshot of my posts section of my admin:
    As you can see, post counts at the top of the page are showing a number of posts, yet they are not appearing in the table below- I find this very odd.

    I am pretty new to doing local development, but am working with a MAMP (v3) setup that seems pretty solid. It also is probably worth mentioning that I have done the migration back and forth at least 3 or 4 times without a hitch. In my failed attempts to troubleshoot this issue I have tried repairing the database tables through phpmyadmin (I can see all of the tables and DB information in there just fine) and even tried creating a completely new database to import to and got the same results.

    If anyone has had experience with this kind of issue or seen anything like this in their wanderings I would really appreciate some help, as I am totally flummoxed here.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi mcurren,

    Are you able to confirm that the posts appear to be visible in the wp_posts table in phpMyAdmin? What about the wp_postmeta table, does everything appear to be there also?



    Hi Chris!

    Yes I can definitely confirm that data is showing in all of the DB tables. I have about 420 lines in the postmeta table alone (I am using Advanced Custom Fields to store a lot of data for the site).

    Another note, if it helps, would be that i’m not using the traditional wp_ prefix for my tables as I was under the impression doing so could be a potential security flaw.

    Let me know if that helps your diagnosis (if any).

    Thanks for the quick response!

    Hi Mike,

    The table prefix isn’t a problem provided you’re using the same prefix for both the site your exporting on and the site you’re importing into.

    i.e. your table prefix can be something like “custom_” but you must be using that on both your sites (production and local).

    Can you confirm that this is the case?



    Yes this is the case. Thanks for double checking.

    Hmm odd problem, do you have WP_DEBUG defined and set to true? If not would you be able to?

    There could be some errors hidden on the post listing page that are currently being hidden.

    You might also want to check if there’s any caching happening. You could manually clear your transients and clear the cache of any caching plugins you have installed.

    Other than that you might want to open up your browser’s debugging console to check if there’s any JavaScript errors occurring on that page.

    Hi Chris,

    Sorry for the late reply- I have had to turn my attention to another project over the past few days.

    I spent some time today going over your suggestions and checked everything. I have enabled WP_DEBUG and installed the Debug Bar plugin but nothing is showing up in terms of errors. It’s really strange.

    I also checked the browser console and see nothing of note, though I’m not to familiar with the debugging tools it has, but I know usually if there are issues of any kind they show up in RED in the console drawer… Let me know if there are specific tests or anything I could be running in there.

    I installed another plugin that deleted the DB transients and optimized the DB supposedly but that did not solve the issue.

    I don’t have any plugins that are doing any caching that I’m aware of – how would I manually clear my WP cache? I added the wp_cache_flush function to my functions.php file and reloaded the page a few times but that didn’t seem to do anything.

    The only other thing I can think of that was changed since the lat time I ported the database back down to my local machine was that we password protected our live dev server using the hosting CP (MediaTemple). could that be causing the issue?

    Also I noticed the “owner” group of the root directory of the dev server is different that the the rest of the directories in the WP install. The “OID” is the same but the”GID” is different – is that something to worry about? Is it related to the password protection I mentioned above?

    Thanks again for your help!

    UPDATE ::

    Hi again Chris,

    I was able to get my local dev back up and running by migrating the site through another plugin (Backup Buddy), so I feel a bit better now.

    That said, I am still curious as to why things stopped working using the Migrate DB plugin… It is a much simpler and less time consuming process for me than doing the migration through Backup Buddy each time, and I am seriously considering having my company purchase a license for your premium plugin but I have reservations after this incident. Not to say that your plugin was necessarily the culprit here- it might be totally unrelated, but I feel less eager to pay good money for something that might not work in the long run.

    Please let me know what types of quality assurances are offered with Migrate DB Pro – is there some sort of money-back guarantee up to a certain point if it stops working mysteriously as Migrate DB seems to have here?

    I’d love to continue this conversation…


    Hi Mike,

    I can say with certainty that the Pro version is much more robust than the current free version. 100s of development hours have been poured into the Pro version to ensure it is top notch in terms of compatibility and reliability.

    It also has the added benefit of being able to perform push/pull migrations.

    I’d be much more comfortable supporting you on the Pro version and to answer your question, yes, we do offer a no questions asked money back guarantee if you have any problems with it.



Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP Content not showing after import’ is closed to new replies.