Support » Localhost Installs » wp-content not found

  • Hi all!

    Just tried setting a WP running on my home NAS (QNAP TS-220) the other day. After some initial fidgeting I got it running and ran into my first real hurdle. The version I had installed through a package file from QNAP contained version 4.0.1 and when I tried updating it the automatic way it gave me an error message that it didn’t find the right folder to be able to go through with the installation. I fidgeted around a bit and came up on a similar problem when I tried installing a new theme (because, I reasoned, getting my site up and running with some themes and stuff was prioritized over installing the latest update for the engine). Here I got the error message that it couldn’t find the wp-content folder. I searched around and finally found this (very) old thread concerning a similar problem.

    I updated my wp-config.php, uploaded it to the server and rebooted the server (dunno if I have to do that honestly). Voila! The update to 4.1.1 worked flawlessly. But sadly the theme installer didn’t work any better, it still gives me the same error message: “Unable to locate WordPress Content directory (wp-content).”

    Before you, might, ask about it: yes, as far as I can see the folder is where it should be on the server. I’m turning to this forum now since I feel a bit dumbfounded when one part of the problem (the upgrade) worked after the “hack” but not the theme bit of the problem.
    Any help is greatly appreciated, thanks!

Viewing 1 replies (of 1 total)
  • Better solution is to add this to wp-config.php file:
    define('FS_METHOD', 'direct');

    Also check the directory ownership and permissions in your wp-content, plugins and themes directories.

Viewing 1 replies (of 1 total)
  • The topic ‘wp-content not found’ is closed to new replies.