[WP Contact Form] - You do not have sufficient permissions to access this page. (8 posts)

  1. Tranny
    Posted 7 years ago #

    I can't seem to be able to access plugin settings page for WP Contact Form. I keep getting this message:

    You do not have sufficient permissions to access this page.

    What's the deal there? Never seen this before :S

  2. metafuel
    Posted 7 years ago #

    Hi, I'm having the same problem. It works perfectly on my other sites with WordPress 2.7 installed. My site on WordPress 2.8.1 throws up the above message every time. I've set my permissions on options-contactform.php to 755 and I still have the problem. If anyone could help I'd be most appreciative. Thank you

  3. ninarizzo
    Posted 7 years ago #

    I have WP 2.8.1 installed and the plugin still works for me, but not fully. The CONTACT FORM itself works perfectly, but the OPTIONS page doesn't show and returns the message "You do not have sufficient permissions to access this page". I tried to fix the problem myself, but I just couldn't make the OPTIONS page show. So I tried something else that works for me, at least until someone comes with a better way to fix this problem.

    How to:

    - At the Edit Plugins, open wp-contact-form/wp-contactform.php and insert the following code BEFORE the plugin code starts:

    update_option('wpcf_email', __('email@provider.com', 'wpcf'));
    update_option('wpcf_subject', __('Contact Form', 'wpcf'));
    update_option('wpcf_showsubject', __('TRUE', 'wpcf'));
    update_option('wpcf_success_msg', __('Thanks for sending your message!', 'wpcf'));
    update_option('wpcf_error_msg', __('Please, fill the required fields.', 'wpcf'));
    update_option('wpcf_question', __('2 + 2 =', 'wpcf'));
    update_option('wpcf_answer', __('4', 'wpcf'));
    update_option('wpcf_casesensitive', __('FALSE', 'wpcf'));
    update_option('wpcf_copy', __('TRUE', 'wpcf'));

    Just change the TRUE/FALSE and another options to whatever you like, just like you would do at the original OPTIONS page.

  4. steveshead
    Posted 7 years ago #

    Same issue here - I upgraded the plugin and now I get "You do not have sufficient permissions to access this page" for all of the links in the control panel that pertain to this plugin. All other plugins seem to work fine - the site is up and stable and the products show just fine on the site. I've tested the process all the way to paying. So, something changed in the latest release that's blown out permissions perhaps?

    Oh - I paid for the Gold Cart but can't get to that screen either. :p

  5. jchronowski93
    Posted 7 years ago #

    How frustrating. I have this issue and also other plugin admin pages have vanished. Front end on most seems to still be working I just can't get in to configure.
    Reverted my WP to 2.7 did not help. Everything comes back if I delete the data from the WP_options table. But I have too many settings to leave it that way. Also I would have to manually reenter all of those settings for each part of my website and every plugin. This could take over a week. So leaving the options data in. I need to know which part of the options table is causing this error? \

    You do not have sufficient permissions to access this page.

    wordpress 2.8.1
    also 2.8.2 did not help.

    Any ideas?

  6. markalex
    Posted 7 years ago #

    Hijacking thread.


    I'm having the same issues with wp-ecommerce 3.7, wordpress mu 2.8.2 and gold card upgrade. any luck?

  7. laowaichinese
    Posted 7 years ago #

    I found a great solution: switch to this plugin

    Just finished testing it. Seems to do everything I want (and the math question automatically changes!).

  8. rsciw
    Posted 7 years ago #

    There's already an update for this problem with wp-contactform available, think it got fixed short after it has been found.


Topic Closed

This topic has been closed to new replies.

About this Topic