Support » Networking WordPress » wp-config settings

  • I have a wpmu installation ugraded to wp 3.0 – it is working well with subdomains.

    I have the following wp-config settings:

    define(‘VHOST’, ‘yes’);
    //define(‘SUBDOMAIN_INSTALL’, true);
    define(‘PATH_CURRENT_SITE’, ‘/wp_mu/’);
    define(‘BLOGID_CURRENT_SITE’, ‘1’);

    define( ‘WP_ALLOW_MULTISITE’, true );
    //define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, true );
    //define( ‘DOMAIN_CURRENT_SITE’, ‘it-gnoth.de’ );
    //define( ‘PATH_CURRENT_SITE’, ‘/’ );
    //define( ‘SITE_ID_CURRENT_SITE’, 1 );
    //define( ‘BLOG_ID_CURRENT_SITE’, 1 );
    define( “WP_USE_MULTIPLE_DB”, false );

    I got the message that VHOST is deprecated and I should use SUBDOMAIN_INSTALL instead.
    If I set this to true the whole installation is no more accessible and I get a message that the database connection is not possible.

    Has anyone an idea how to set those constants?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    It looks like you have some things duplicated… Cleaned up some:

    define('SUBDOMAIN_INSTALL', true);
    define('PATH_CURRENT_SITE', '/wp_mu/');
    define('BLOGID_CURRENT_SITE', '1');
    define( 'WP_ALLOW_MULTISITE', true );
    define( 'MULTISITE', true );

    This should be SINGLE quotes, not double

    define( "WP_USE_MULTIPLE_DB", false );

    Also all these are commented out. Why?

    //define( 'DOMAIN_CURRENT_SITE', 'it-gnoth.de' );
    //define( 'PATH_CURRENT_SITE', '/' );
    //define( 'SITE_ID_CURRENT_SITE', 1 );
    //define( 'BLOG_ID_CURRENT_SITE', 1 );

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Please, do not put in the multisite constants if you are upgrading from wpmu. there’s no need to, WordPress can tell.

    define( ‘WP_ALLOW_MULTISITE’, true );
    define( ‘MULTISITE’, true );

    take these out.

    The only things you shoudl have done on upgrade was this:
    http://wpmututorials.com/how-to/upgrading-to-3-0/

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘wp-config settings’ is closed to new replies.