WordPress.org

Support

Support » Installation » [Resolved] wp-config reportedly missing

[Resolved] wp-config reportedly missing

  • Hi,

    I’m relatively new at WordPress. I downloaded and installed last summer on a plesk server and everything went fine. At least I don’t recall having a problem.

    Yesterday I tried downloading and installation on the SAME PLESK server, but for a different domain. I followed all the directions in the “famous 5 minute install” and I have a Visual Quickstart Guide as well. However, every time I try to run the …/wp-admin/install.php step, I get a page of code with the message toward the top “wp-config.php seems to be missing”. I tried it several times, even uninstalling and reinstalling the database and user on the server.

    This morning, I uninstalled the database and user once again, deleted all wordpress files from my computer and started fresh with a new database name, new user and a new password. Fresh new wp-config.php file. I even uploaded from a different computer and still I get this page of code with the “missing wp-config.php” message.

    I haven’t really seen anything that sounds like the same problem here on these boards, so now I’m officially asking for some insight. It must be something I’m doing wrong, but I can’t, for the life of me, figure out what!

    Thanks in advance!
    Michelle in Brooklyn

Viewing 6 replies - 1 through 6 (of 6 total)
  • whooami

    @whooami

    Member

    most common cause of that error: no wp-config.php

    a link to what you are seeing might help us.

    I checked several million times: the wp-config.php file is there. With the correct information filled in for database, username, password, etc. I’m really tearing my hair out. I’m currently re-uploading (this makes the 6th time?), so once I come to that page, I’ll post the link.

    Ok, here goes: my not-working-blog.

    Oh – one other thing: you may notice in this instance I put the blog in its own directory. This is the second attempt at THAT. All the other tries have been with the blog right at the root – which is what I really want.

    Thanks in advance, again!
    Michelle

    whooami

    @whooami

    Member

    that site isnt set up to properly serve php files. What you are seeing is raw php. Your wp-config.php is probably spitting out lots of valuable info like your databse name, mysql username and passwd.

    You need to rename that file immediately, change that password, and speak with the host.

    Thanks, I will. The odd thing is I set up WordPress last summer on the same host, but for a different domain and it works fine. The other thing I just found out is there’s an application vault at the host where I could “install” WordPress, but it’s version 1.5.1

    Okay, thanks for your help. I’ll give them a call.

    whooami

    @whooami

    Member

    well, do this, create a phpinfo file:

    <?php phpinfo(); ?>

    copy that bit of code into a file named whatever you want, so long as it identified as a .php file ie, call it blah.php, mine.php whatever you want, and load that up in your browser.

    If you have php available, that will display all kinds of stuff, if you see what you pasted, then its a server issue.

    Thanks for that idea – I’ll write that inside my book and keep it for future reference. As it is right this second, I’m, once again!, re-uploading the files after having changed the db names, etc etc. I went in through admin for the domain and added the php checkbox. Let’s see if it works….

    Yes, yes, and yes again! Thank you so much for your help! I knew it would be a glaring, stupid small omission and you can BET it will never happen to me again! Whoohoo!!

    Have a great afternoon!
    Michelle

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] wp-config reportedly missing’ is closed to new replies.
Skip to toolbar