Support » Installing WordPress » wp-config.php V. wp-install.php

  • There doesn’t seem to be a wp-config.php file. Double check that you updated wp-config.sample.php with the proper database connection information and renamed it to wp-config.php. Obviously, the error is easily recognizable. However, having upload the wp-config several times. The index of my files here shows that there is indeed a config. To my best knowledge i’ve filled in the config correctly. So any have a clue as to what i’m messing up? I fillied in the root of my database which is harkey (in config), I also made a databse called wordpress located @ harkey_wordpress .
    Am I using the wrong db for connection?
    Personally i liked the good ol .sql or .txt file to create tables.
    ~Hark

Viewing 6 replies - 1 through 6 (of 6 total)
  • Has the user ‘wpusr’ been given access to the database ‘harkeyahh_wp’?
    Mike

    yeah

    Have you placed a prefix before the table name? I had errors before I “got it” and put a prefix there. 🙂 I run more than one copy of WP, so I put in a prefix. I don’t know if you have to do this or not, but it’s something you may want to check.
    Also you may want to check that your config.sample.php is deleted. What I did was made a copy of it. I changed the copy, renamed it to config and uploaded that one. I never have a sample.php in my directory on the site. Just one of those things.
    When you made your MySQL database, you did make a user and add that user right? You have the right password in the config.php correct? Just trying to troubleshoot, silly questions, I know. 🙂 One thing I caught myself doing the second time I installed is forgetting the information at the top of the file. I was just doing the tables. It won’t work if you don’t have the database in there.

    $table_prefix = ‘wp_’; // eg ‘wp_’ or ‘b2’ or ‘mylogin_’
    $tableposts = wwb2. ‘posts’;
    See the ww before the b2? I added that. It’s for a blog I have that has the address ww. Does that make sense?

    Thanks got it up n running.

    Hey Guys,
    I have the same problem like harkey. My knowledge is not very good, so can anybody please help me?
    “There doesn’t seem to be a wp-config.php file. Double check that you updated wp-config.sample.php with the proper database connection information and renamed it to wp-config.php.” I’ve uploaded the config file, but I’m not sure if I filled in everything correctly.
    Especially the thing with the table_prefix. Sould I do there something or not?
    Hope anybody can give me an advice.
    (sorry for the bad english)

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.