Support » Installing WordPress » wp-config needed?

  • I have just tried installing WordPress, I followed the instructions, even the dumbed down version. After that I clicked on “/wp-admin/install.php” and am getting this error below.
    ==============================
    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.”); require_once(‘../wp-config.php’); require(‘upgrade-functions.php’); if (isset($_GET[‘step’])) $step = $_GET[‘step’]; else $step = 0; ?>
    ===============================
    Then there is “WordPress” in large letters and this error below.
    ================================
    hide_errors(); $installed = $wpdb->get_results(“SELECT * FROM $tableusers”); if ($installed) die(__(‘
    You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.
    ‘)); $wpdb->show_errors(); switch($step) { case 0: ?>
    Welcome to WordPress. We’re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. Before we get started, remember that we require a PHP version of at least 4.1.0, you have . Look good? You also need to set up the database connection information in wp-config.php. Have you looked at the readme? If you’re all ready, let’s go!
    =========================================
    I have checked and the wp-config.php is on my server, I have renamed it making sure the sample part is removed so it just says “wp-config.php”. I have spoke to my friend who created the mySQL database for me today and gave me the information. I have even tried deleting the files and reuploading them. I have tried doenloading the wordpress file and starting from scratch.
    I cannot think what ekse to try.
    TKA
    here is my wp=config.php file:
    =========================================
    <?php
    /** WordPress’s config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘spacespi_jafo’); // The name of the database
    define(‘DB_USER’, ‘spacespi_jafo’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘*****’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define(‘ABSPATH’, dirname(__FILE__).’/’);
    // Get everything else
    require_once(ABSPATH.’wp-settings.php’);
    ?>
    =======================================

Viewing 10 replies - 1 through 10 (of 10 total)
  • Mark (podz)

    (@podz)

    Support Maven

    Looks like you are seeing raw code.
    Do you have php installed ?
    PHP Info
    * Paste this into a new Notepad / BBEdit file
    * <?php phpinfo(); ?>
    * Save as ‘info.php’
    * Upload to server. Visit in your browser (www.example.com/info.php)
    * That will give you info about your php version
    Do you see a big page of info after doing that ?

    I created the info.php file in notepad, it gives the file but as a text file? Think I misunderstood you very new to php.

    Mark (podz)

    (@podz)

    Support Maven

    If you have php installed, you should see something similar to this:
    http://www.tamba2.org.uk/INFO.PHP
    The code I used was just
    <?php phpinfo();?>
    in a file.
    It looks like you need to ask your host to install php for you….

    ok I created the php file in dreamweaver and I got this:
    PHP Version 4.3.8
    Then there is a whole lot of info under that. I have been at this since this morning so not very swift upstairs tonight, try doing this and learning to bake a cake for your wife all in one day 😉

    Mark (podz)

    (@podz)

    Support Maven

    Link to your site ?

    Mark (podz)

    (@podz)

    Support Maven

    And what sort of cake ?
    🙂

    Link:
    http:// jafo.spacespider.net/
    where I want to have the weblog:
    http://jafo.spacespider.net/parlezvousfrancais
    Cake:
    Chocolate with pink icing :0

    Mark (podz)

    (@podz)

    Support Maven

    Oh … it just installed….. sorry …
    email me and i’ll send you the password ?
    tamba2 at gmail dot com
    (I clicked install to see the error messages and they never came!)
    (and pink ??)
    🙂

    ok I e-mail you it will come from ricjoe at gmail.

    And thank you for all your help with this. It is much appreciated
    LipSkid 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘wp-config needed?’ is closed to new replies.