WordPress.org

Forums

[resolved] Wp-config error (12 posts)

  1. mall19
    Member
    Posted 9 years ago #

    I am only 1 hour new to WordPress, so please cope with me. =) I did take a look around the Support Forum already, but none of them really does help.

    Anyway, I got a problem with my wp-config. I am 90% sure that I fill in the form correctly. However, I recieved the "error" page when I viewed wp-admin/install.php , though. I am not sure what I did wrong, but here is the code that I used on the wp-config

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'mall'); // The name of the database
    define('DB_USER', 'malll'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxxx'); // ...and password
    define('DB_HOST', 'ftp.pixelfx.org'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    ---

    Was there anything that I did wrong? I really appreciate it if you would help me out with this. Thanks. xx

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    We need the exact error you saw.

  3. mall19
    Member
    Posted 9 years ago #

    The admin.php page said this:

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at http://ftp.pixelfx.org. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

  4. CarolineG
    Member
    Posted 9 years ago #

    I see: http://ftp.pixelfx.org as the DB_HOST
    try: 'localhost'

    And is your sql username Malll or Mall?

  5. mall19
    Member
    Posted 9 years ago #

    My SQL User is malll (with 3 Ls)

    *Sigh* Let's hope I do this right...

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'malll'); // The name of the database
    define('DB_USER', 'malll'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxxx'); // ...and password
    define('LOCALHOST', 'ftp.pixelfx.org'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  6. CarolineG
    Member
    Posted 9 years ago #

    try localhost instead of http://ftp.pixelfx.org.

    And your db username is malll, with 3 lll? The first time your had mall...

  7. mall19
    Member
    Posted 9 years ago #

    Thanks for helping me, really, I appreciate it. But it seems like it still doesn't work

    Below is the Error page of admin.php :

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

  8. CarolineG
    Member
    Posted 9 years ago #

    Try this:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'mall'); // The name of the database
    define('DB_USER', 'malll'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxxxx'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
    --------------------------------

    And be sure to insert the correct username and password and database name!

  9. mall19
    Member
    Posted 9 years ago #

    I'm sure that I got the correct username and password. But just to make me 100% sure - is the database name supposed to be made-up or would your hoster provide you with the database information? If that's not clear, what "is" the database name?

  10. CarolineG
    Member
    Posted 9 years ago #

    You should have a database setup allready, you cannot just invent one. And if you have one, it has a name. That name you should use in the wp-config.

    So check what your database name is, or if you don't have a database create one, or have one created for you by your host.
    Then use that name, and of course the database username and password that comes with it.

  11. mall19
    Member
    Posted 9 years ago #

    Problem solved. =) I forgot to contact my host for MySQL database. Thanks for helping me! It's greatly appreciated. =)

  12. CarolineG
    Member
    Posted 9 years ago #

    So you got it to work?
    Great!

Topic Closed

This topic has been closed to new replies.

About this Topic