Support » Developing with WordPress » wp-cli package install problem

  • billc108

    (@billc108)


    On attempting to install wp-doctor, or any other wp-cli package. When I run

    wp package install <package name>

    or

    sudo wp package install <package name>

    I’m getting:

    Error: The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl extension, you can disable this error, at your own risk, by setting the ‘disable-tls’ option to true.

    Openssl version 1.0.2k_0 is installed (via MacPorts, in /opt/local/bin/openssl). Do I need to specify that path somehow?

Viewing 1 replies (of 1 total)
  • Daniel Bachhuber

    (@danielbachhuber)

    Hi @billc108,

    From this Stack Overflow thread it seems like you need to either enable the OpenSSL PHP extension, or recompile PHP with OpenSSL enabled:

    while one cannot simply “enable SSL in the php.ini” on Linux; PHP needs to be compiled with openSSL configured as shared library – in order to be able to access it from the PHP CLI SAPI.

    There’s also this Stack Overflow thread which mentions:

    In addition to uncommenting the ;extension=php_openssl.dll line in php.ini that everyone else has mentioned, you also have to ensure the ;extension_dir = “ext” line is also uncommented. To uncomment, remove the prefixed semicolon and save.

Viewing 1 replies (of 1 total)
  • The topic ‘wp-cli package install problem’ is closed to new replies.