Support » Plugin: Import Listings into the Jobify Theme » WP-CLI import error

  • Resolved lens2016

    (@lens2016)


    Hi, I wanted to switch to wp-cli import but I always get the following error, do you have any suggestions?

    PHP Fatal error:  Uncaught Error: Call to a member function can_update_meta() on null in /wp-content/plugins/jobify-xml-csv-listings-import/jobify-add-on.php:222
    Stack trace:
    #0 /wp-content/plugins/jobify-xml-csv-listings-import/rapid-addon.php(399): jobify_addon_import(91912, Array, Object(PMXI_Import_Record), Array, Object(Closure))
    #1 /wp-content/plugins/wp-all-import-pro/models/import/record.php(3224): RapidAddon->import(Array, Array)
    #2 /wp-content/plugins/wp-all-import-pro/models/import/record.php(333): PMXI_Import_Record->process('<?xml version="...', Object(Closure), 2, true, '/pmxi_records', 1, Object(cli\progress\Bar))
    #3 /wp-content/plugins/wp-all-import-pro/classes/cli.php(95): PMXI_Import_Record->execute(Object(Closure))
    #4 [internal function]: PMXI_Cli->run(Array, Array)
    #5 phar:/// in /wp-content/plugins/jobify-xml-csv-listings-import/jobify-add-on.php on line 222
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author WP All Import

    (@wpallimport)

    Hi @lens2016,

    Unfortunately, our Jobify Add-On hasn’t been updated to work with WP-CLI imports yet. We do plan on doing that, but I don’t currently have an ETA for the release.

    For now, you’ll have to use regular cron jobs ( http://www.wpallimport.com/documentation/recurring/cron/ ) or manually run the import.

    Thread Starter lens2016

    (@lens2016)

    Thanks. I have too many imports to run so it is nearly impossible to time it correctly with normal wget cron jobs. I regularly run into import issues because of overlapping imports and server time outs. The WP-CLI import works so much better and runs all 20 jobs one after another…so no trouble at all.

    Guess I will need to set up all the jobs again with the Wp Job Manager Addon and custom fields which seems to support WP-CLI. Keep me updated when you have updated your add-on, since its been more than a year and a half you started the WP-CLI support so its a bit sad that your own add-on is not supporting it after that long of a time.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WP-CLI import error’ is closed to new replies.