Support » Plugin: Multisite Plugin Manager » WP-CLI cannot display all Plugins anymore

  • Resolved Jan Thiel

    (@janthiel)


    Hi Aaron,

    we stumbled over some issues using your plugin in combination with WP-CLI.
    We run the latest WordPress (4.9.1) with latest WP-CLI (1.4.1). Using you plugin in this combination hides all plugins which aren’t controllable on a single site (thus being forced activated or network activated) from the WP-CLI. The issues just started recently as we used your plugin for a long time with no issues.

    The issue looks like the following:

    
    wp plugin list --all
    +-------------------------+----------+--------+---------+
    | name                    | status   | update | version |
    +-------------------------+----------+--------+---------+
    | affiliate-wp            | active   | none   | 2.1.8   |
    | bne-flyout              | inactive | none   | 1.3.3   |
    | duplicate-post          | inactive | none   | 3.2.1   |
    | fv-wordpress-flowplayer | inactive | none   | 6.3.11  |
    | gravityforms            | active   | none   | 2.2.5   |
    | LayerSlider             | inactive | none   | 5.6.9   |
    | wordpress-seo           | active   | none   | 5.9.3   |
    | a-mu-plugin             | must-use | none   |         |
    | sunrise.php             | dropin   | none   |         |
    +-------------------------+----------+--------+---------+
    

    Which should look like this:

    
    wp plugin list --all --skip-plugins=multisite-plugin-manager
    +-----------------------------------------------+----------------+--------+---------+
    | name                                          | status         | update | version |
    +-----------------------------------------------+----------------+--------+---------+
    | affiliate-wp                                  | active         | none   | 2.1.8   |
    | antispam-bee                                  | active-network | none   | 2.7.1   |
    | bne-flyout                                    | inactive       | none   | 1.3.3   |
    | cloner                                        | active-network | none   | 1.7.7   |
    | cms-tree-page-view                            | active-network | none   | 1.4     |
    | cookie-notice                                 | active-network | none   | 1.2.40  |
    | domain-mapping                                | active-network | none   | 4.4.2.5 |
    | duplicate-post                                | inactive       | none   | 3.2.1   |
    | dynamic-widgets                               | active-network | none   | 1.5.13  |
    | fv-wordpress-flowplayer                       | inactive       | none   | 6.3.11  |
    | duracelltomi-google-tag-manager               | inactive       | none   | 1.7.2   |
    | gravityforms                                  | active         | none   | 2.2.5   |
    | gravityformscli                               | inactive       | none   | 1.0     |
    | gravity-forms-google-analytics-event-tracking | inactive       | none   | 2.0.9   |
    | gravityformsuserregistration                  | inactive       | none   | 3.8     |
    | LayerSlider                                   | inactive       | none   | 5.6.9   |
    | simple-jwt-authentication                     | active-network | none   | 1.1     |
    | wordpress-importer                            | inactive       | none   | 0.6.3   |
    | wp-piwik                                      | active-network | none   | 1.0.19  |
    | wp-fail2ban                                   | active-network | none   | 3.5.3   |
    | wp-mail-smtp                                  | inactive       | none   | 1.0.2   |
    | wpmudev-updates                               | active-network | none   | 4.4     |
    | wp-smush-pro                                  | inactive       | none   | 2.7.6   |
    | wordpress-seo                                 | active         | none   | 5.9.3   |
    | a-mu-plugin                                   | must-use       | none   |         |
    | sunrise.php                                   | dropin         | none   |         |
    +-----------------------------------------------+----------------+--------+---------+
    

    It might be related to WordPress 4.9 / 4.9.1 and the multisite changes the core team built in. We haven’t encountered this issues earlier and haven’t updated WP-CLI since it was still working.

    Thank you for your support and best Regards,

    Jan

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WP-CLI cannot display all Plugins anymore’ is closed to new replies.