Support » Installing WordPress » WP Can’t select database?

  • Resolved 5thape


    I’m upgrading to WP2.0. I’m trying to open wp-admin/upgrade.php in my browser but I get an error message that says,

    “Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the wordpress database.”

    Does anyone know what the problem is or how to solve it? I followed the upgrade directions perfect.

    – Austin

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m haveing the exact same problem, so some help here would be great.

    You have the right information in wp-config.php in regards to your database username and password and your WP database name?


    Same problem here too. But all I’ve done is try to back up my database. I downloaded my whole WordPress blog folder. All the files are still in place where they were before I downloaded them (so copying the files not moving them). I then tried to do the back up using phpMyAdmin (as you should do) and the database is not selectable and I get the same screen in my browser as highlighted in the first post in this thread. What’s up with that?

    I’m having the same problem. Username and pwd checked and passed, local host configged correctly, and db name copied and pasted (for accuracy) off the mysql admin page. I even moved everything out of the root directory into a less cluttered WP directory. Same issue. Any one know what to do?

    I solved the problem, but I don’t know why the solution worked. I deleted the new database that I had created especially for wordpress (xxxxxx_com_-_wordpress), and created a new one especially for wordpress (xxxxxx_com_-_wp). Now it works.

    Good luck to the rest of you.

    It looked like my WordPress database was working again today, but didn’t have the time to look at it properly until now and it’s not working again, with the same problem as before!

    Cavebutter: You deleted the new database especially for WordPress and then created a new one especially for WordPress…? If this is correct, then I don’t know why it works for you either!

    My database is just for WordPress, and is litterally called ‘wordpress’; no prefixes or suffixes to confuse things.

    It couldn’t be my host could it? I have another database for a forum and that’s not had any problems.

    Ok, I got fed up with not being able to connect to my database, so I went ahead and did a new install and it worked… for an hour or so, then the same old problem came up again. But I figured out why, and it’s very odd. The database only ‘dissapeared’ when I logged into my web hosting account. Then being logged off a while my database worked again. So I logged back into my web hosting account and step by step I looked to see what I did that made the database dissapear. Turns out it’s when I access phpMyAdmin! And I confirmed this by doing it a second time when the database ‘came back’. I’ve asked my web host why this is the case, but yet to hear anything back. So, for now at least, I guess I can’t be using phpMyAdmin for backup purposes.

    I got this reply from my hosting company

    “Rather than logging into the DB server and then selecting your database, your scripts should directly log into your database. Since each username only has access to one database, there’s no need to select your database after connecting.”

    Didn’t really help me, but I know it’s not WordPress’ fault as the problem ONLY happens when I log into phpMyAdmin I’ve discovered.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP Can’t select database?’ is closed to new replies.