WordPress.org

Forums

wp-cache trying to work but not working (15 posts)

  1. Mike1
    Member
    Posted 7 years ago #

    I upgrade from 2.2.2 to 2.2.3 around the same time I moved the site to another server, not sure which one might be the cause if either are.

    The plugin (2.1.1) is activated and enabled. In the options menu the 'Cache contents' always show '0 cached pages' and '0 expired pages'. But I do see the cache show up in the cache directory. Viewing the page source it is showing the page isn't cached. The delete cache button does actually delete the cache, but when the page is visited again the cache is created but still shows 0 on the page and wp doesn't use the cached page.

    I have used wp-cache on the site for a couple years now with no issue, so I'm kinda stumped.

    I have disabled, deactivated and deleted the plugin along with the cache directory and installed the plugin fresh, hasn't helped.

    Apache 2.0.61
    PHP 5.2.4
    Apache and PHP have also been update recently.

  2. Chris_K
    Member
    Posted 7 years ago #

    Do you have:

    define('WP_CACHE', true); //Added by WP-Cache Manager

    in your wp-config.php file?

  3. Mike1
    Member
    Posted 7 years ago #

    define('WP_CACHE', true);

    Just no comment. :)

  4. Chris_K
    Member
    Posted 7 years ago #

    Drat!

    You have the symlink created (as mentioned in manual installation)?

  5. Mike1
    Member
    Posted 7 years ago #

    The symlink is there, I deleted and recreated it manually which didn't help. I forgot I had another blog also recently upgraded to 2.2.3 on the same server, wp-cache is working fine with it. I went thru and compared permissions and settings between the two and couldn't find any differences.

    So it still has me stumped.

  6. Cal
    Member
    Posted 7 years ago #

    I have this error too, I can see all the cached pages in the folder but it says "0 pages cached" ......

    Which I know is wrong.....

    Not the end of the world I guess, at least it is caching.....

  7. Mike1
    Member
    Posted 7 years ago #

    But is wp actually displaying the cache page.
    For me it isn't.
    Look at the page source. If you don't have this at the bottom, it is not cached.
    <!-- Cached page served by WP-Cache -->

  8. Cal
    Member
    Posted 7 years ago #

    Hmm, I didn't know that, you learn something new every day.

    my page says this
    <!-- Dynamic Page Served (once) in 1.095 seconds -->

    I'm using wp version 2.2.1

  9. Cal
    Member
    Posted 7 years ago #

    Edited a couple times :)

    Okay, this plugin is working fine on another site I have, but it's on a different host....As far as I can tell though, the cache settings look fine in both wp installs.....

    So here's some more info on my hosting
    PHP Version : 5.2.1

  10. Cal
    Member
    Posted 7 years ago #

    Updated plugin to version 2.1.2 and still doesn't work :(

    Does anybody have any ideas on this........

  11. felipelavinz
    Member
    Posted 7 years ago #

    I'm having the same issues with WP-Cache... I'm on DreamHost, using PHP 5.2.3, WordPress 2.2.3 and Fast-CGI... disabled Fast-CGI and nothing changed, so I'm guessing this is about PHP5; I used to have PHP4 (no Fast-CGI) and WP-Cache worked fine.

    As it has been said, the problem it's that WP-Cache is caching pages but not sending them to the user, so everytime a request is made, the plugin re-generated a new cached file, which requires even more work than no cache at all.

    The strangest thing it's that it apparently works on 'tags' pages (using Ultimate Tag Warrior).

    I'll try to update to WP 2.3 and see what happens... if nothing, I don't really know if I'll switch back to PHP4/No-FastCGI/WP-Cache, since PHP5/Fast-CGI/No-WP-Cache CPU time it's practically the same :P

  12. felipelavinz
    Member
    Posted 7 years ago #

    Sorry, that was supossed to go here: http://wordpress.org/support/topic/124764

    Got mixed-up with so many open tabs :|

  13. mildlyhotpeppers
    Member
    Posted 7 years ago #

    Has anyone come up with a solution? It seems like I'm experiencing the same thing...

  14. GregMcAbee
    Member
    Posted 7 years ago #

    All,

    I fixed this error for my site http://www.godsmessageontheweb.net this evening. My issue started after my WordPress site was hacked. After my ISP did a restore it just would not work. I tried everything listed above.

    My advanced-cache.php file in the wp-content directory actually was being represented as a folder instead of a file. I could not even delete it with my FTP software. So I used the File Manager on the ISP to delete and re-uploaded it from my last backup and it started working right away.

    You might want to look through your structure and verify no other .php files are being represented as directories. I hope this helps someone out there.

    God Bless,
    Greg McAbee

  15. theloonyape
    Member
    Posted 7 years ago #

    I had this problem too. Apparently the solution is rather silly.

    If you added the line define('WP_CACHE', true); directly to your wp-config.php, you need to make sure it is at the top, just under the // ** MySQL settings ** //.

    I shifted it from the bottom of the wp-config.php to the top and it works now, weird problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags