Support » Plugins » WP-Cache Not Caching Pages

  • Greetings,

    I’ve installed and configured the plugin with no problems on the latest version of WordPress running on PHP5. I did the little hack for PHP5 in one of the config files, and I also have made sure the WP_CACHE bit is in the wp-config.php file.

    It all seems to be right, but no pages are being cached. I can verify this by seeing that nothing’s being created in the wp-content/cache directory, and the WP-Cache text is not being put at the bottom of my pages. Plus the plugin options show 0 pages.

    So the last thing I’m thinking is permissions, but I think those should be right too. I have all directories (including wp-content and cache) owned by the web user, and the permissions are 755 like they should be. I simply don’t see any reason why this isn’t working.

    I’ve seen the other threads, by the way, and those were always either issues with the PHP5 tweak, or a problem with permissions; nobody’s addressed this specific issue. If you have any ideas I’m very eager to hear them.


Viewing 8 replies - 1 through 8 (of 8 total)
  • Seemingly you are mixing two different things:
    1. The WP-Cache plugin
    2. The totally useless “caching” feature of WP, which you activated in the config file. No need for that if you are using the plugin, which is recommended for sites with high traffic.

    As for the Pages I can’t remember now how does it work. Sorry.

    I wrote a short post on installing WP-Cache, maybe you’ll find it useful. From the sounds of your problem, it look like a permissions thing or a symbolic link thing.

    I am having a similar problem with wp-cache not caching. It used to work, but I moved my wordpress installation from the root directory of the webserver to a subdirectory, it no longer caches. I have to reinstalling the wp-cache plugin to no avail.

    I’m trying to install the latest version of wp-cache on WP 2.0.7 after my host freaked out about processor load.

    Yes, I know, old version of WP, but the ill effects of an upgrade to 2.1 scarred me for life. Rolling back was not fun. Also, I’ve read about successful installs on versions as early as 2.0.5, so would that really be the problem?

    Plugins: SK2, Akismet, Bad Behavior, Dean’s Permalinks, Feedburner Feed Replacement

    I’m not getting any errors, but there’s no actual caching happening — no comment in the HTML source code.

    * I’ve read every troubleshooting post and page that I can find.
    * I’ve tried setting permissions to 755, 775, and 777 on the various files and folders.
    * I have the “define…TRUE” line in the config file.
    * I have a symbolic link and it’s pointing to the right place.

    It’s just not working.

    Please. If there’s a thread that I’m missing somewhere that anyone knows of, I’d be grateful for the help. Or even any troubleshooting suggestions.

    This is nuts, but…

    I moved the define('WP_CACHE', true); statement in the wp-config.php file to the top of the file. Just above the MySQL settings, immediately after <?php and now wp-cache is humming happily along.

    Here is how I solved the exact same problem:

    — I must say that I installed the plugin & afterwards moved the site from a subfolder of the www to the www itself. That’s when the plugin stopped working. I can’t guarantee it will solve any other problem than moved wordpress 

    I checked permissions and this wasn’t the problem. So I started looking for symlinks, and here is what I found in the /home/www/wp-content folder:

    70 Sep 2 12:31 advanced-cache.php -> /home/www/subfolder/wp-content/plugins/wp-cache/wp-cache-phase1.php

    As I already said, the site was moved Out of the subfolder and placed into the main “www”. So I deleted the symlink and created it again:

    ~# rm –rf advanced-cache.php
    ~# cd /home/www/wp-content/plugins/wp-cache/
    ~# ln –s home/www/wp-content/plugins/wp-cache/wp-cache-phase1.php advanced-cache.php

    This solved the issue and no problems experienced afterwards.

    I hope it helps.

    that’s great and all, but how do you fix the symbolic link if your host doesn’t give you a shell?

    for what its worth, I was having the same problem with a clean install but no caching.

    I too just moved the define('WP_CACHE', true); up toward the top (I put mine just below the db login info) and it immediately started to cache – shows up on the options page and I can see it via FTP as well.

    Thanks for that fix.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP-Cache Not Caching Pages’ is closed to new replies.