WordPress.org

Support

Support » Plugins and Hacks » [Resolved] WP-Cache killed my site! Please help!

[Resolved] WP-Cache killed my site! Please help!

  • Hi all,

    I just installed the WP-Cache plugin as some folks were complaining of speed issues. As soon as I clicked “enable,” it took down my site! I can’t even get into the Dashboard to disable the plugin.

    My site is fjetsam.com – but going there now brings up an error message related to the plugin.

    I don’t know the first thing about code, but if any of you can steer me in the right direction to get this fixed it would be greatly appreciated.

Viewing 5 replies - 1 through 5 (of 5 total)
  • FTP to /wp-content/plugins/wp-cache.php and delete it. That will deactivate the plugin.
    What version of WP are you using that you need it?

    WP-Cache also adds a line to wp-config.php that you’ll need to remove.

    Thanks for the help. I’ve deleted the plugin and edited the code, and I can definitely tell I’m making progress — but I’m not quite there yet. Now I receive some different error messages. When I try to go to the main page I get;

    Fatal error: Call to undefined function wp() in /mnt/w0110/d18/s46/b029f009/www/fjetsam.com/wp-blog-header.php on line 16

    And when I try to go to admin I get;

    Fatal error: Call to undefined function get_option() in /mnt/w0110/d18/s46/b029f009/www/fjetsam.com/wp-admin/admin.php on line 7

    Is it more code that WP-Cache put in? I’ve looked at both files and both lines, but I just don’t know enough about these things to know how much I should be removing (or if I should be removing anything at all.)

    Also – if it comes down to it and I have to reinstall WordPress, and I going to lose all of the changes I’ve made to my layout and my posts?

    Well, five hours of fiddling and struggling later, it looks like I just deleted the wrong part of code.

    The important thing is it’s fixed! Now I have to go about fixing all the parts of my site I lost when trying different things to fix it.

    Despite my own idiocy that lead to this, I’d like to thank you guys for helping. If it wasn’t for you I’d still be sitting here hacking away in all the wrong areas.

    Muchos Gracias!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] WP-Cache killed my site! Please help!’ is closed to new replies.
Skip to toolbar