Support » How-To and Troubleshooting » WP-Cache & WP-Super Cache Increasing CPU Usage

WP-Cache & WP-Super Cache Increasing CPU Usage

  • I’m trying to help somebody fine tune their WordPress install on a VPS and suggested that they try either WP-Cache or WP-Super-Cache to lessen the load that the blog creates on the server. Upon trying this, both plugins actually seem to drive the load up considerably and crash their VPS. I’m sure it’s a plugin conflict, but I was curious to know if anyone else had seen this behavior – and if so, what they did to remedy it.

    I appreciate any guidance you can provide and will be glad to give anyone more info if necessary.

Viewing 15 replies - 16 through 30 (of 47 total)
  • I’m having problems too please help us all!

    How much memory does your account have?

    Same happens for me on my dreamhost vps. I really want to use a cache plugin, but I’m not able to because my #’s go way up. Plus I get a ton of comments on my site, and have about 6800 posts, so I’m not sure if that’s a realistic goal.

    Try the Lockdown feature – even if you get lots of comments they won’t appear until you explicitly clear the cache. That should help a lot but it may piss off your users.
    Otherwise, get a bigger server. Sounds like you have quite a big blog!

    Having same exact issue as rfischmann.

    Was recently moved to private Dreamhost server and within a few minutes experienced a spike in memory usage to the point where free memory went to 0 and the site became inaccessible.

    I determined WP-cache was causing the memory issue because after disabling the plugin memory usage quickly goes back down to appropriate levels.

    Dreamhost has recommended trying Super-cache, but I wouldn’t be surprised if it causes the same issue…

    i have same problem with WP2.5, mine is shared hosting, my provider have suspended my account 3 times and finally they said there is no way to continue with this shared hosting, now I’m VPS account, but still I’m getting this issue again.

    If Gzip compression is enabled – it needs to use more CPU.

    And I have a proposal for plugin. Is to set max CPU load value for blog (for example 5%). So if the CPU load is higher WPCache gives only cached pages and doesn’t allows to generate new pages (gives some predefined screen “Sorry, the server is gone”).

    I had a problem with my hosting too. So wrote a little script that checks CPU load and gives only error screen if needed. So it would be good to give any information available in static.

    Posterd – unfortunately checking the CPU load isn’t a practical solution. How do you do it on a Windows box?
    Running “uptime” or executing a shell command is the easiest way I know of doing it in PHP and that causes load itself and only works on UNIX hosts.

    I’d like to hear from people who have this CPU load problem – does it go away if you disable compression?

    Hello Donncha, I’m facing exactly same problems as rfischmann right after moving to DreamHost VPS from shared hosting. And for the past one+ month my blog is just dead. And top of all, I’ve started receiving about 500 trackback/pingback spams every single mintue, draining all available resources.

    I’ve tried all possible HTACCESS rules to avoid spammers generating PHP load, but to no avail., I’m truly sure, I’ve done something wrong.

    To cut short, the only alternative is to move elesewhere, as suggested by DreamHost.

    I just cann’t go elsewhere (as suggested by some senior support members), because $70 advanced payment is quite big amount for me, and I cann’t affoard to loose it.

    Still awaiting their reply, meanwhile the site as usual remains dead as it takes 4+ minutes to each HTTP request and dies with 500, 404, error establishing database connection etc. errors.

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    And top of all, I’ve started receiving about 500 trackback/pingback spams every single mintue, draining all available resources.

    Rename or remove wp-trackback.php and xmlrpc.php to stop this for the time being. It’ll kill trackback and pingback abilities, but the load will stop.

    Hi Otto, did as you adviced. Just wondering, I’ve tried HTACCESS rules available on many well known blogs, claiming good % of success. But those rules are not working when I add into my HTACCESS (public folder).

    500 spams a minutes, it seems DOS HTTP attack.

    Here’ is an example rule that’s failing to work:

    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteRule .* - [F]
    RewriteCond %{REQUEST_URI} .no-spammers.php*
    RewriteCond %{HTTP_REFERER} !.*mydomain.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule .* - [F])
    RewriteCond %{REQUEST_URI} .*/trackback/?.*
    RewriteRule .* - [F]

    If the ip is the same, you can use this .htaccess to avoid connections:

    <Limit GET HEAD POST>
    order deny,allow
    deny from
    deny from
    deny from
    deny from
    deny from
    deny from

    Did you install mod_security or bad_behaviour?

    I have both and both are very useful to block intruders, spammers and hackers

    Being on DreamHost at the moment, I probably may have mod_security installed.

    At the plugin front I’m using Akismet & WP-SpamFree.

    FWIW, I had the same problem described here, and am also at Dreamhost. It happens with the latest versions of WP-Cache and WP-Super-Cache: a few minutes after activation, whammo, the number of httpd instances goes sky high, consuming available memory.

    What I did to fix it, was move the cache directory from wp-content/cache (NFS mounted) to /tmp/hostname-wp-cache (local) by changing the relevant line in wp-cache-config.php. Luckily my cache maxes out at about 10M, so it fits well in /tmp: YMMV.

    distobj – good idea, but that probably makes it possible for other sites on your servers to overwrite your cached files. Does each Dreamhost account have their own user id? Can you read or write /tmp/ files created by others?

Viewing 15 replies - 16 through 30 (of 47 total)
  • The topic ‘WP-Cache & WP-Super Cache Increasing CPU Usage’ is closed to new replies.