Support » Plugins » WP-Cache – 0 cached pages

  • Hi all. I’ve installed WP-Cache and enabled. No errors, but the options page shows “0 cached pages” all the time – so basically it’s not doing anything.

    I’ve seen a few similar questions on here but can’t seem to find an answer for this problem – any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The following folders have to be chmod-ed to 777 (readable/writable/executable by all users) for wp-cache to work:


    You can do this from your host’s cpanel or webftp.

    If it doesn’t work you can try chmod-ing these too:


    realepicurean – are there any files in your cache directory? There are in mine, even though the options pages shows 0 pages. Every time I check the HTML source on the blog (even when I’m not logged in) – it shows that the page is being dynamically loaded.

    By the way, are you using mfunct for anything?

    wooptoo – 777? Really? Giving the “world” write privileges. I’m not security nut; but I do believe in locking my doors.

    wooptoo! thanks for your comment!
    now my page is flying!

    man, this plugin should come included as default. 🙂

    tbojustin I got the same problem as well — The pages are cached but non of them are being listed as being cached.

    I have tried to get a hold of the developer but that seems to be useless. Maybe someone that knows him can kick him to this post and make him read it.

    realepicurean forgotten create a symbolic link
    cd /home/blog/; ln -s /usr/home/blog/ advanced-cache.php
    My DocumentROOT for domain

    I have this same problem. Files appear to be cached, and the cache folder fills up. But none are being listed in the admin. panel. I will have to investigate on my own.

    In my scenario the .meta files are never written, but the .html files are. The list reflects the presence of .meta files, so if those aren’t being generated, the list of cached files will be empty. I also suspect that although a time appears at the bottom of files served, they are not being served from the cache. So caching isn’t really working. Why?

    I’ve traced the problem to line 237 inside wp-cache-phase2, this tests for a $new_cache = true, trouble is $new_cache is always false and won’t get set to true until wp_cache_ob_callback gets called. In my setup, it doesn’t get called until after the test… not sure why…

    I’ve tried both wp-cache and wp-supercache, and neither of them are working in my 2.5.1 blog. Read the read me for both dozens of times. htaccess checks out. I don’t have the advanced-cache, and I can’t figure out the symlink thing! Not sure what it is- a text?- or where to put it.

    Any ideas, please?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP-Cache – 0 cached pages’ is closed to new replies.