Support » Plugin: WP Biographia » wp-biographia don't display in single post's

  • Resolved Santaclaes

    (@santaclaes1)


    Hi, I really need some help getting wp-biographia going on http://naturlivet.se/
    I’ve tried a bunch of things to make it display in single posts but I can’t make it work. It displays fine on pages but not on single post’s. My template (wpTuts) single post file has this code in it:

    <div id="post-author" class="clearfix">
                    <div id="author-avatar">
    					<?php echo get_avatar( get_the_author_meta( 'user_email' ), apply_filters( 'platformbase_author_bio_avatar_size', 50 ) ); ?>
                    </div><!-- END author-avatar -->
    
                    <div id="author-description">
                    	<h4>Om författaren</h4>
    					<?php the_author_meta('description'); ?>
                    </div><!-- END author-description -->
           	</div><!-- END post-author -->

    Any ideas on how I can implement the plugin in single posts?

    Thanx!

    http://wordpress.org/extend/plugins/wp-biographia/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author vicchi

    (@vicchi)

    This should be pretty straightforward. The post template you’re using has author information hard-coded into it, so unless you want to duplicate some information you’ll need to comment the code you’ve shown above out. This is basically what FAQ 5 is saying …

    I’ve installed and configured WP Biographia and now I see not one but two differing Biography Boxes; what’s going on?
    There’s probably one of two things going on here. Firstly, you’ve already got another plugin that makes a Biography Box installed and active and this plugin, as well as WP Biographia, are doing their job properly. Secondly, the theme you’re using hard codes a Biography Box into the theme templates. Both the TwentyTen and TwentyEleven themes supplied as part of a standard WordPress install do this.

    You can either delete the code, or comment it out, along the lines of

    <!--
    <div id="post-author" class="clearfix">
        <div id="author-avatar">
        <?php echo get_avatar( get_the_author_meta( 'user_email' ), apply_filters( 'platformbase_author_bio_avatar_size', 50 ) ); ?>
        </div><!-- END author-avatar -->
        <div id="author-description">
            <h4>Om författaren</h4>
    	<?php the_author_meta('description'); ?>
            </div><!-- END author-description -->
    </div><!-- END post-author -->
    -->

    [Moderator Note: Please post code or markup snippets between backticks or use the code button.]

    Then simply ensure your author (or author’s) profile(s) have biographical information set in them and ensure that “Display On Individual Posts” is checked in WP Biographia’s settings and options and you should be good to go.

    -Gary

    Thank you so much for the response!
    I realize the post template I’m using has author information hard-coded into it and tried commented that part out but then nothing displays, I’ve never had double boxes displayed. I just can’t seem to get the WP Biographia box to display. And I’m positiv that “Display On Individual Posts” is checked.

    My single.php:

    [90 lines of code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    Plugin Author vicchi

    (@vicchi)

    Check that your user isn’t suppressed in WP Biographia’s settings/options and that your user doesn’t have the “Don’t show the Biography Box on your posts” setting checked.

    -Gary

    NO user is suppressed and the “Don’t show the Biography Box on your posts” setting is NOT checked. If I have all the boxes for “Individual Posts”, “Front Page”, “Post Archives” and “Individual Pages” checked the only on that work’s is “Individual Pages”.

    Thanks again for having a look at this for me.

    Plugin Author vicchi

    (@vicchi)

    OK. Can you see what the contents of the wp_biographia_settings array is in your database (you’ll find it in the wp_options table) and paste it into this forum thread?

    -Gary

    Sure! Is this what you are looking for?
    Download RTF File

    Plugin Author vicchi

    (@vicchi)

    That’s exactly what I’m looking for. Thanks. Let me digest this.

    -Gary

    Plugin Author vicchi

    (@vicchi)

    The only thing I can see in your database settings is that it looks like you’re using a custom post type called “slides” … is this the post type you’re trying to display the Biography Box on?

    You have the display of the Biography Box on single posts turned on (s:27:"wp_biographia_display_posts";s:2:"on";) but on the “slides” post type it’s turned off (s:28:"wp_biographia_display_slides";s:0:"";).

    -Gary

    Plugin Author vicchi

    (@vicchi)

    Any update on this?

    -Gary

    Tell you what Gary, I kinda gave up on this. My custom post type is not the problem and I seem to be loosing this battle. I even tried with another theme and the problem is still there. What function or string of code triggers the plugin to display?

    Plugin Author vicchi

    (@vicchi)

    So this is really odd. To answer your question, the plugin hooks into the the_content and/or the_excerpt hooks (dependent on the theme and/or template) to trigger the display, based on the plugin’s configuration. As you’re running on the latest released version, v2.4.4, want to try out the beta of v3.0, which is code complete?

    -Gary

    Plugin Author vicchi

    (@vicchi)

    v3.0 is now out of the door; let me know if you still have this problem.

    -Gary

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘wp-biographia don't display in single post's’ is closed to new replies.