WP Backup/Restore new version (77 posts)

  1. J3r0m3
    Posted 12 years ago #

    when i tried to backup my database i got this:<br>Warning: passthru() has been disabled for security reasons in /home/linguagy/public_html/test/wp-admin/backupRestore.php on line 49
    when i tried to download my WP files, i got this:
    Warning: passthru() has been disabled for security reasons in /home/linguagy/public_html/test/wp-admin/backupRestore.php on line 80
    Whats going on?
    please help

  2. Anonymous
    Posted 12 years ago #

    This update was posted June 20, '04 by Laughing Lizard as: WordPress 1.2 One Click Backup
    A new version of the backup scripts for WordPress 1.2 Mingus is now available. This has been tested with 1.2 Mingus and the instructions have been updated along with some of the code.
    Some of the new and original features are:
    One click backup of the WordPress MySql database which can be then downloaded from your browser without the use of any FTP client.
    One click backup of all the files inside your WordPress folder which can then be downloaded from your browser.
    Date coded backup named for sql files and zipped WordPress files.
    Better checking of user level. This menu is only available to users with level 10 (or admin) and every backup/restore script has user checking built in to prevent un authorized usage of this tool.
    One click restore of database (if you have a Linux server)
    More streamlined SQL creation resulting in faster backups and cleaner dumps. Please download the zip file from:

  3. tomjkiehn
    Posted 11 years ago #

    I'm having problems restoring my blog.
    Before I switched to my new server I copied all files from my site onto my local computer and made an SQLdump with LaughingLizards hack.
    Now, on my new server, I have uploaded the old files, installed the newest version of WP and LL's restore hack. When I log into WP I can see my restore .sql file on the BackupREstore page. I click to restore it and, even though it says "restore was sucessful", nothing is restored.
    Any ideas?

  4. Mark (podz)
    Support Maven
    Posted 11 years ago #

    Download that file, and restore it through phpmyadmin.
    Bottom half of the page. Post back if you get stuck / are unsure :)

  5. Anonymous
    Posted 11 years ago #

    Thanks, Podz, for the help. I am still having some problems though.
    First of all, I only have a .sql file. I don't have that zip file that the tutorial you refered me to references. Perhaps that is my problem?
    When I try to restore the .sql dump through PHPMyAdmin it just hangs there for about 15 minutes and eventually gives me the following:
    Fatal error: Maximum execution time of 300 seconds exceeded in /usr/local/cpanel/base/3rdparty/phpMyAdmin/libraries/read_dump.lib.php on line 77

  6. Mark (podz)
    Support Maven
    Posted 11 years ago #

    The .sql file will be fine - it's the one I use.
    How large is the .sql file you have ?
    I would suggest splitting the .sql file into two.
    - get pspad ( http://www.pspad.com ) - it can handle sql files.
    - COPY THE SQL and work from the copy !
    - open the sql file in pspad.
    You will see stuff like this:

    # --------------------------------------------------------
    # Table structure for table wp_categories
    CREATE TABLE wp_categories (

    and following that, all the data for that table.
    Then there will be a gap, and it will show similar stuff for the next table.
    What you need to do is split your sql file into two, but without splitting a table.
    So from the start of the file, if you highlighted to about halfway through the document, and stopped the highlight at one of the
    lines, then 'cut' and 'saved as an sql file' (it's name does not matter) then saved what was left as another sql file, you would have 2 files to import.
    That should then work.
    But PLEASE work from a copy !
    If I've not been clear enough - it's getting late here :) - post back.

  7. NeuroCide
    Posted 11 years ago #

    Up until 2 days ago my Backup/Restore was working perfectly, the SQL database and the WP files were being backed up and stored fine in the directory. Now after New Year's, (i've made no changes) the WP files still backup fine but the SQL database doesn't. It tells me that the database backed up fine, and all is well and gives me a link to the SQL file, but the SQL file is never created. The tar file still is created and works.

    Any ideas? Could it have anything to do with the date?

  8. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Did you host change PHP or MySQL? Try to backup the database manually, see if you have any difficulty. http://www.tamba2.org.uk/wordpress/backup/

  9. NeuroCide
    Posted 11 years ago #

    My host hasn't changed PHP or MySQL but you know I did add two more tables that are not wp_ related to my same database. They don't have the wp_ heading, and they are for another function. Could that have anything to do with it?

  10. James Huff
    Support Team Rep.
    Posted 11 years ago #

    I don't know. Can you manually backup your database using the tutorial given above?

  11. NeuroCide
    Posted 11 years ago #

    Yes, I can manually back them up in phpMyAdmin. Any suggestions?

    I tried backing up just the WP tables separately and then all my tables (wp ones and non-wp ones...meaning the full database). Both worked fine through phpMyAdmin.

    Don't know whats up.

  12. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Probably related to the two non wp_ tables then. The usual trend is to use one database for WordPress and accompanying plugins.

  13. NeuroCide
    Posted 11 years ago #

    macmanx: The other two tables are being used for an accompanying plugin. They're not totally unrelated to WP, they just don't have the wp_ template tag at the start.

    I can't figure out why it just stopped working. :-(

  14. limeshurbet
    Posted 11 years ago #

    Updated version of Laughing Lizard's One-Click Backup/Restore for WP 1.5 Beta.


    This works for me on 1.5 01.04.05 nightly. No guarantees though, so you should NOT install this in your production blog and you should NOT do anything if you don't know what you are doing.

  15. limeshurbet
    Posted 11 years ago #

    I corrected the filename so the link should work now.

  16. paperlion
    Posted 11 years ago #

    Hope this is not off-topic...

    Is there an interchangability between backups created with phpmyadmin and those done through 1-Click Backup or straight sql commands?

    Say for instance I discover a backup file (done in one of the two former ways) is too big and creating out-of-memory errors during restore attempts. Can the files be made over for command line use?

    This happened during an actual (attempted) restore to a new installation.


  17. Laughinglizard
    Posted 11 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic