Support » Plugin: RPS Include Content » WP automatic video embedding does not work

  • Resolved kalico

    (@kalico)


    WP allows for automatic embedding of videos with just the URL. But when I pull that content to another page or site (on my multisite), it just displays a plain link.

    This is a test page demonstrating the problem:
    http://nrocnetwork.org/7438-2/

    This page contains the following code:

    [rps-include blog=30 page=18098 filter=true]
    
    [rps-include blog=30 page=18100 filter=true]
    
    [rps-include blog=30 page=18107 filter=true]
    
    [rps-include blog=30 page=18109 filter=true]
    
    [rps-include blog=30 page=18111 filter=true]

    On this page, you’ll see that there is a plain video link at the top of the page, as well as plain video links on the “Video” tab just below. The plain link at the top was a test to isolate the link from the tabs, just to be sure it’s not being messed up by the code for the tabs (Tabby plugin), but that doesn’t seem to be the problem.

    Here is the first page referenced in the code above (18098), which demonstrates how I would expect the above demo page to look/behave:
    http://nroc.org/media/nroc/

    Thanks for looking at this.

    • This topic was modified 2 years, 4 months ago by kalico. Reason: clarity
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author redpixelstudios

    (@redpixelstudios)

    Thanks for the thorough description of the issue. We believe that we have addressed the issue with a new version (1.1.10).

    A new shortcode attribute has been added to allow the processing of embeds. It has been set to not process embeds by default to avoid any display issues on sites that are currently using RPS Include Content. It should look something like this:

    [rps-include blog="30" page="18098" filter="true" embeds="true"]

    We have done preliminary testing but would appreciate it if you could try the new version to make certain it meets your expectations. You may download it from the wordpress.org repository.

    Once we receive confirmation from you, we will go ahead and release the version to the general public. Thanks in advance.

    Yes! Beautiful fix. Thank you so much!! 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WP automatic video embedding does not work’ is closed to new replies.