Support » Fixing WordPress » WP and Plugin updates – Can't create tmp file

  • Hi,

    Today we tried to update WP to 3.9 (from 3.8.1) and it said:

    Below code is for Contactform 7 update, but the error of creating tmp fail is also when trying to update to 3.9)
    Warning: touch() [function.touch]: Unable to create file /home/fotowgt67/domains/ because No such file or directory in /home/fotowgt67/domains/ on line 155

    Warning: unlink(/home/fotowgt67/domains/ [function.unlink]: No such file or directory in /home/fotowgt67/domains/ on line 500

    It can’t create or write to the tmp files.

    I already tried things like CHmod 777, and I also tried;

    define( ‘WP_TEMP_DIR’, ABSPATH.’wp-content/tmp/’) ;

    But this didn’t help. I contacted my host and they said they don’t help with script related issues.

    What to do now?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I would Cry..

    A lot of people are having problems with WP 3.9 Updates

    First I would make sure you have a full backup of your files and database.

    Then I would turn off all of your plugins and turn on a default WP Theme like TwentyTwelve

    Then try the core Update
    Once you get that going you want to make sure that all plugins say 100% compatible with WP 3.9

    then update one plugin at a time.

    You can also try FTPing the plugins it may work.

    I manually uploaded the new 3.9 files from the 3.9 zip, but I still get the message when updating plugins that it can’t create a temp file.

    Would like to know the answer to this as well. Seems like file.php has just disappeared from within the core structure of the WordPress package. Would it be possible to repair this issue by just importing the file.php .. well, file, manually into /includes ? I guess not since it could break everything down into pieces, but maybe someone can reach us a helping hand. Thanks in advance

    Try this. It worked fine for me.

    The link tells you to add the following to the bottom of your wp-config.php file:
    define('WP_TEMP_DIR', ABSPATH.'wp-content/uploads/');

    If you get a “Division by Zero” warning after modifying your wp-config.php file, you should check that you used the correct quotation marks, because PHP is fussy. If you still get a “Division by Zero” warning, try this instead:

    $path = $ABSPATH .'wp-content/uploads/';

    @joe Nasevich, I already tried both of them but that didn’t help.
    I keep getting Division by Zero, but your fix doesn’t help.

    I already downloaded WordPress and just overwrite all files but that didn’t help either.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP and Plugin updates – Can't create tmp file’ is closed to new replies.