Support » Plugin: Mihdan: Ajax Edit Comments » WP Ajax Edit Comments is Broken

Viewing 15 replies - 16 through 30 (of 31 total)
  • I was a user of pay version. So, I found the support email address and sent an email about this the day before yesterday. I’ve not had a reply yet. I wonder I’ll have a good news. I hope so but have little hope. If I give up this plugin, it’s a shame for it.

    By the way, I think v5.0.7.0.’s trouble has roots in owner and permission of the directory ‘aec’. Why do I think so? Because, on my own server, its OS is WindowsXp Professional Sp3, the plugin works. Other my sites on Linux server I had trouble. As we know, WindowsXp server has poor owner and permission managements. And most people say the older version works and it does not have the directory ‘aec’.

    At any rate, v5.0.7.0. is not a WordPress plugin, I think. A WordPress plugin is easy to install and easy to activate. Soon you can use it. That’s a WordPress plugin.

    Also, both older and new version have an error, ‘Stack overflow at line: 2’ from IE and ‘too much recursion’ from FireFox. Most of people are unaware of it in normal use. But it’s for real. It is probably from some JavaScript codes. I want to fix it if they can.

    I almost forgot to write. When you try other versions, you’d better clear your browser cash. Or, you don’t get new effects well.

    I got a wrong spelling.
    Of course, it means ‘cache’, not ‘cash’. 🙂

    I have not seen your “Stack overflow” error and wonder if it’s specific to your server. Meantime, I tried installing every which way, double checking that permissions and group settings were correct (they were). Still won’t work. My current server is a standard Linux box with Debian.


    Hi, Gene,

    Thank you for your testing.

    Do you have 6 files in your ‘aec’?
    Depending on server types, the plugin creates no files in it at all.

    For the past week, I understood a lot of different situations exist for each user. I don’t know what it depends on. It’s kind of confusing.

    By the way, I forgot to write. “Stack overflow” is a client side error.
    It sometimes appears, when a user tries to edit his/her comment on the post by IE8.

    What constitutes an aec? I have no such folder within this plugin’s files.


    What? You don’t have the directory ‘aec’. You installed v5.0.7.0., didn’t you?
    Why did you talk about nothing with it on your post before this one?

    As I wrote, the major difference between v5.0.7.0 and the older version is the directory ‘aec’. Because of that, various troubles occur, I think. So, it is very important the plugin can create this directory or not. It is also important who is the owner of ‘aec’ and what permissions are set to them, I mean ‘aec’ itself and the files in it.

    You wrote:

    I tried installing every which way, double checking that permissions and group settings were correct (they were).

    So, I think you followed my 10 steps and failed. But you didn’t so, please test again if you have time.

    My ten steps are too much of a bother.
    So, I wrote

    At any rate, v5.0.7.0. is not a WordPress plugin.

    But the order of my ten steps is very important. If you try, please follow the order indicated.

    For well working of the plugin, you have to make ‘aec’ under /wp-content/uploads manually.

    I did this a couple of times. The uploads/aec directory and contents were ll changed to 777. No difference. It does not work. The change in permissions gets me the icons next to Edit that are otherwise not visible, but the Edit function fails to produce the message I want to change.

    Meantime, the previous version works. This does not. Why go through hoops to fix something that’s broken.

    That the authors aren’t responding to my direct emails to test and fix the problem indicates to me they just don’t care.


    Thank you for your testing.

    I think that is unfortunate. I myself tried it on Linux servers at four free web hosting services. I don’t know what distribution they use. Three of them worked and the rest one didn’t. On this, the plugin cannot create ‘aec’ and its files at all.

    For my mail they aren’t responding, either. About a week has passed.
    Last December, when I asked them “Please tell me for whom I send the new language file.”, they answered nothing. A shame.

    Yeah, I cannot believe the authors are so tone deaf as to be unaware of this.


    I also emailed iThemes and told them to stop sending me solicitations for commercial themes and plugins until they fix this thing!

    Suggest everyone do that.




    I’ve just downloaded the older version, and it’s working fine on WordPress 3.4.2, so I’m happy at last!!

    I can’t believe that the ability to edit comments isn’t standard on all blogs – if you spot a typo afterwards, it’s stuck there for posterity. I hate leaving mistakes uncorrected.

    Plugin Author Ronald Huereca


    I’ll probably push an update this weekend, but for any of you experiencing write-permission errors, can you try the development version on Github?

    I am curious if it fixes your issues.

    Wow! Welcome back, Ron!

    Yesterday, I was compared with v., v. and your 5.0.13.

    And today, I have tested your until now. I say it’s great.
    I installed it by my Admin panel in the morning. I feel it works great.

    Please check it out. When I installed v., it did not delete the sub directory “aec” at the uploads directory. But I think it is not necessary anymore, right?

    Here is the Japanese language zip for v.

    I forgot to write about the below.

    When using the edit feature, the expand window does not work well.

    I can edit my comment and have the message “Comment successfully saved”, but I don’t have the popup window at that time, the window for editing appears in its parent window. My browser is IE10 on Win8.

    > When using the edit feature, the expand window does not work well.

    I figured out. The option “Enable Colorbox on the front-end?” was “No”. I changed it to “Yes”. Now, the expand window works fine.

    Thanks a lot.

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘WP Ajax Edit Comments is Broken’ is closed to new replies.