WordPress.org

Support

Support » Plugins and Hacks » [Resolved] WP Ajax Edit Comments is Broken

[Resolved] WP Ajax Edit Comments is Broken

Viewing 15 replies - 1 through 15 (of 31 total)
  • In my case, the recent versions are broken because they don’t work properly. Click Edit and it doesn’t load the message. This is a bug that has existed for several versions, and it seems the author(s) are tone deaf about the need to fix the problem. I’m not alone in reporting such issues.

    Peace,
    Gene

    Hey, WP Ajax Edit Comments plugin developers! Please fix your wonderful plugin! ๐Ÿ™‚

    I wrote to the company who had previously offered this as a premium plugin, and they said they’d let the developers know.

    Haven’t heard anything since. ๐Ÿ™

    Peace,
    Gene

    Seems like a sneaky way to get rid of the free version which still works! Guess I’ll edit the plugin to remove auto updates and get rid of the update nag.

    There isn’t a paid version anymore. They released it as free, but they don’t seem to be paying much attention to making it work.

    Peace,
    Gene

    @ wholmes ยป Could you please provide a link to a functional package of the plugin, once you’ve down this quick fixing?
    Thanks in advance!

    Folks, this version, the link provided by one of the former authors, works:

    http://aecpublic.s3.amazonaws.com/wp-ajax-edit-comments.zip

    Peace,
    Gene

    Thanks @genesteinberg I was just about to respond with a link. So it’s going to be a free plugin again… well then I was wrong it’s not a conspiracy as I had thought. lol!

    Today, probably I made it.ใ€€Now I’m going to talk about ‘How to use Ajax Edit Comments v5.0.7.0’. ๐Ÿ™‚

    Though I wrote about this on my blog, I post here again.

    I still have two errors, ‘Stack overflow at line: 2’ from IE8 and ‘too much recursion’ from FireFox 9.0.1. But the plugin works in a sort.

    1. Install Ajax Edit Comments v5.0.7.0. But, when you finish installing it, you never activate it immediately.
    2. Access your server by FTP client software.
    3. Make directory ‘aec’ under /wp-content/uploads and change its permission to ‘707’ or ‘777’.
    4. Activate the plugin from your Dashboard.
      You need 7 files in your ‘aec’ directory, admin.js, edit-comments.css, ajax-edit-comments.js, comment-editor.css, frontend.js, popups.js and index.php. At this point, only two files exist there, admin.js and edit-comments.css.
      When you click ‘Update Settigs’ bottun on the AEC setting page, other 4 files are created.
      About index.php you have to make it manually, and write in it   ‘<?php // Silence is golden.’.
    5. About 6 files are created automatically, their owner is server and they are unwritable. If you use shell or something, change owner and permission by it.
    6. If you can’t use such tools, follow the next steps.
    7. Access your server by FTP client software.
    8. Download directory ‘aec’ and remove it.
    9. Remake directory ‘aec’ under /wp-content/uploads and change its permission to ‘707’ or ‘777’.
    10. Reupload 6 files, admin.js, edit-comments.css, ajax-edit-comments.js, comment-editor.css, frontend.js, popups.js and change their permission to ‘606’ or ‘666’.
      Upload index.php to directory ‘aec’.

    That’s it. Good luck. ;-P

    Take a look at what you’re saying. You can download an older version of the plugin that pretty much just works, or you have to go through 10 levels of nonsense to force a buggy version to mostly work.

    Which do you think is the better solution?

    I have my answer, until or unless the programmers figure out how to fix their problem.

    Peace,
    Gene

    Thanks Gene.

    I have this older version. When did he upload it?

    Unfortunately, the errors which this older version also has.

    If the programmers don’t do it, I can’t be helped to throw out the plugin.
    But it’s a shame for it.

    I have no problems with the older version.

    Peace,
    Gene

    Here’s the problem I was having with AEC and how I (seemingly) fixed it.

    I have two, single install, WordPress sites. One is the live site at http://www.musiclibraryreport.com and the other is mlrtest.com (a duplicate of musiclibraryreport.com). Both have the exact same plugins, theme and both with the same host.

    On mlrtest.com AEC worked fine but on musiclibraryreport.com when trying to edit a comment the following message was displayed in the edit box – “Fatal error: Call to a member function get_admin_option() on a non-object in /home/munson/public_html/musiclibraryreport.com/wp-content/plugins/wp-ajax-edit-comments/views/comment-editor.php on line 74”. This occurred both on the front end and on the admin side at musiclibraryreport.com.

    I seem to have fixed the problem by deleting AEC, installing the older version and then updating to 5.0.70.

    Hope that may help someone.

    But why not just use the older version? Is the newer one benefiting of special features critical to your blog that the older one didn’t have?

    Peace,
    Gene

    P.S. Updating from old to new doesn’t do it for me. Just loses Edit functionality (nothing loads).

    The older version wasn’t working for me (tried that first). When I tried to edit a comment I would get a grayed out screen and there was no edit box with the comment that I wanted to edit. That’s when I thought I would try updating the older version and that fixed it for me.

    BTW the older version had been working for me but seem to break within the last few WP upgrades.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] WP Ajax Edit Comments is Broken’ is closed to new replies.