Support » Fixing WordPress » /wp-admin/upload.php – The connection was reset

  • So I’ve installed wordpress on my own server for the first time running:

    • 2003 server entreprise (iis6) SP2 (32 bit)
    • PHP 5.4.5
    • MYSQL MS
    • FAST CGI (fcgisetup_1.5_rtw_x86.msi) WP (latest)

    Installation worked ok – but when I login (which works) some pages wont load like when i click on media (htttp:// it just times out and the error message in the FF shows up:

    The connection was reset

    The connection to the server was reset while the page was loading.

    The site could be temporarily unavailable or too busy. Try again in a few moments.

    If you are unable to load any pages, check your computer’s network connection.

    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

    I have abosluty no clue on how to solve this – I been googling but have found nothing usable about this topic.

    same thing happens aslo on:

    In the page /wp-admin/media-new.php im expering an error to – It’s not specified but the files are not uploaded – the error just say’s “http error”.

    Thanks a bunch in advance! 🙂

    Kind regards

Viewing 15 replies - 1 through 15 (of 15 total)
  • Have you tried this in a different browser? IE, Chrome, Safari ?

    Hi and thank you for you reply.

    Wel I have treid it with all major browsers and if you click on the “media” (upload.php) and all other links mentioned it just times out.

    I have no clue on how to fix this – I’m a totally newbie on WP 🙂



    Moderator Mark Ratledge


    Forum Moderator

    This has nothing to do with WordPress and everything to do with your server setup. Multiple fixes:


    Just some questions:

    How come its just these pages that get reset and not the rest of the php and normal html files that works fine?

    Why this behvior on just some of the files and not all of them? aka what the cause of this issue? (normally)

    The setup for iis 6 is pretty standard so.. I’m just curious.. 🙂

    I’m not a super duper wiz om copmp. but mostly I can get them where I want so I’m very greatful for all info.

    Thanks a lot!

    Thx Songdog I agree, and @angrywarrior his link above has alot of info on it. I would go with something in a Linux flavor myself 🙂 but I know that is not always an option so reading up on it is the best option in that case. Also speak to the guys at Woothemes they have a wealth of info on their themes and best practices for setup.

    Well thanks 🙂 but I know how to getaround with windoze, changing to linux would just make it even worse for me as I do not know how to code linux – it’s not user friendly enought for me – but thx for the suggestion. I understand why poeple use linux – but too nerdy for my flavour of preference 🙂

    I’m trying to dig into this issue – but I still do not understand the root cause and why the comp cuts the connection (or what the source is that could cause this is in windoze / iis 6)

    I been looking on the google ( the suggestion above) but I do not even know where to look almost, but I’m trying to dig into the info in the google results. Nothing yet, though….



    I understand Daniel you can seek out some other WordPress Windows users however you really wouldn’t need much “Linux” knowledge to get the WordPress running, best of luck and if you do find a solution let us know 🙂

    Thanks alvaw – I will do that when / if I found a solution to this issue.. 🙂

    Just at thought that just struck me.. (after reading tons of articles on the without finding a solution):

    Is the default upload folder hardcoded in wordpress?

    I have set my upload folder location in php outside the iis inetpub location outside in a another place on the hard disk because of security and the fact that I may want to install other website apps than wordpress and I do not want to limit the upload ability to just the wordpress installation. Now if im right and wordpress is looking inside its installation directory and the directory 1) is missing (i cannot find it) and 2) the files are not uploaded there anyway the connection would just reset without any errors as WP just stops the whole operation and quits.

    Just a long shot – I really hope I’m right because (and that it’s the cause of the issue) I’m almost given up on this issue.

    And by the way – I have been googling but I cannot find where the uploads folder resides in wordpress..

    Is it: C:\path\to\wordpress\wp-content\uploads? – f so.. funny I do not even have the folder there..




    I don’t think it is related to the Hosting, as I am getting this error even on my blog

    when I try to login to this URL:
    I got the error “The connection was reset”

    So I have always to login to main wordpress website:

    then I navigate to my website, I found that I am logged in.



    Forum Moderator

    These forums are for self-hosted WordPress sites only. Please try asking your question on




    I am the proud owner of my own Microsoft 2003 server SP2 with wordpress installed on it. And I own everything from the hardware to the software itself. Actually I own serveral servers but never mind.. 🙂 I cannot be more selfhosted than that!



    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    I cannot be more selfhosted than that!

    Agreed! And I am sure Esmi meant ameen.rabea who actually is on WordPress.COM. 😉



    To ameen.rabea..

    I do not know what setup you have, but I gave up this installation which was a manual installed WP – nothing worked with uploads.php page and not really no help to be found on the internetz if you are a Microsft server owner since most if not all subjects on the issue relates to Linux and apache..

    So I throw in my towel in the ring and deleted the (damm thing) php 5.4 + whole database and WordPress installation on my server and used the automated installation from Microsoft (Microsoft Web Platform Installer) which installs php, mysql, fast-cgi and wordpress all in one time..

    That worked very well!

    So If you have Microsoft server 2XXX with iis and choose to do the same as me, just remember to change the settings you do not like in php and sql and so on.. and of course other security settings..

    all the best,



    AHHH ok!

    I cannot be more selfhosted than that!

    Agreed! And I am sure Esmi meant ameen.rabea who actually is on WordPress.COM. 😉

    I did not catch that part! – I could have savced me from the time writing the little “book” above! 🙂 Not that I mind though.. I like to help if I can…

    Thanks Jan!


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘/wp-admin/upload.php – The connection was reset’ is closed to new replies.