[resolved] Not responding load-scripts.php so busy! (3 posts)

  1. enseitankado
    Posted 6 years ago #

    I have an interesting problem after i installed WP 3.

    When I try to edit a post wp not responding and waiting.
    FireBug console says the page waing for load-script.php (http://www.tankado.com/wp-admin/load-scripts.php?c=1&load=jquery,utils,quicktags,editor&ver=f219d9ebfeb10659e7038094a3f50ef1) And couldnt edit a post.

    I tried some methods to fix

    1. I manually upgraded WP (wp-admin, wp-includes and root)
    2. Disabled all plugins (Also I moved the plugins folder)
    3. Checked wp-config.php
    4. I setted PHP Memory Limit to 256MB in php.ini (and wp-config define)
    5. I checked file system permission and ownering (centos linux)
  2. esmi
    Forum Moderator
    Posted 6 years ago #

    Have you tried re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

  3. enseitankado
    Posted 6 years ago #

    Finally, I found the reason of busy page.
    This is an realy exceptional situation...

    Source of problem is gzdeflate function in load-scripts.php at line 134. I think that it output an malicious data to browser and browser waiting forever... If I select a different compression level diffent from 3 then problem solved.

    Also, load-scripts.php script reads four js file into variable named $out then compress it and output to browser. Scripts are below:


    If I change the content of any one of the js files above then problem fixed. I prefer to set compression level to 9.

    I will try to debug of crafted output of gzdeflate.

      I'm using;

    • WordPress 3
    • PHP 5.1.6 (cli) (built: Mar 31 2010 02:44:37)
    • Apache Server version: Apache/2.2.3 Server built: Apr 4 2010 17:19:54

Topic Closed

This topic has been closed to new replies.

About this Topic