WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] wp-admin/index.php working, wp-admin getting 404

[Resolved] wp-admin/index.php working, wp-admin getting 404

Viewing 5 replies - 1 through 5 (of 5 total)
  • maybe your host doesn’t have index.php enabled for directories

    Hey Samboll,

    Thanks for the response.

    I do have an index.php in the root folder, with
    <?php
    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);
    require(‘./wp-blog-header.php’);
    ?>

    and if I delete the home.php file within the theme (that is acting as my homepage file), it does recognize the index.php file in the theme folder. Would this contradict the host issue, or no?

    I haven’t had this issue before, so not sure.

    the home.php shouldn’t conflict
    what I’m getting at is the host may very well have index.php enabled in the root but not directories – like /wp-admin

    add this to your .htaccess file in the root on 1st line
    DirectoryIndex index.php index.html

    should work

    That was it!

    Thanks samboll!

    Much appreciated.

    Samboll, you rock!!! Been banging my head forever. Was this issue. Thanks!!!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] wp-admin/index.php working, wp-admin getting 404’ is closed to new replies.