Support » Fixing WordPress » WP ADMIN : Sorry, you are not allowed to access this page

  • hi iam a newbie with wordpress, and i have been using my wordpress smoothly without any problem for the past few months now, but for like one week now if i log in to my wp-admin it tells me “Sorry, you are not allowed to access this page”… please someone help me with.. i cant access my dashborad

Viewing 15 replies - 31 through 45 (of 59 total)
  • So I have cross checked the table prefix and the wp_config. No references in the database to the old prefix, everything is using the new standard wp_ prefix. Still no closer to figuring out why I’m getting this error. Most of the site works fine. Here’s what happens:

    I log in.
    I get the “Sorry …” message.
    Delete /wp-admin/ from the URL.
    Home page shows as it should with the control bar at the top.
    Drop down menu with site name on the top left does not work, it does not appear on mouse over. The top left W menu item works as it should.
    If there are updates I cannot access them by clicking the Updates icon in the top bar. Clicking the Comments icon in the top bar correctly takes me to the list of comments.
    I am now in the dashboard.
    The drop down menu with the site name now works and shows “View site” on mouse over.
    I can go to users to delete users, but I am unable to edit users.
    The Updates menu item is inaccessible, but I can perform all updates either on the plugins page or on the themes page.
    I used to run Jet Pack for statistics, but I am no longer able to activate it (I get the same Sorry… message).

    I am not sure what else I can tell you. I am not even sure when this all started, it has been like this for so long I’ve forgotten.

    There are so many posts about the prefix causing this and most of them say that that could be “one of the reasons” for this error, but I have yet to find a single post about any alternative reasons. If wp_users and wp_usermeta are free of errors, then what could be doing this, and how could I go about fixing it? Is there an easy way to move just posts and media to a clean WP installation? I did use the Duplicator plugin, but it is now giving me a “You do not have sufficient permissions to access this page” when I try to create a new archive of the site so using that is out.

    Any help?
    Any paid support services I can use?

    Best regards
    Geir

    Dear Geir,

    If you are intimate with PHP and MySQL, you could just invest the time and step through the code and see where ELSE that message is raised. I had found the table name mismatch as being the cause when I had tracked down the problem in the WordPress code last time, thus had no reason to look beyond that.

    Otherwise, I hope that someone will be able to point you to paid WordPress or third-party service option.

    If everything else fails, you could take a MySQL backup of your WordPress database. I could attempt to restore it on one of my test systems and see if I can reproduce your wp-admin problem on my end without needing any of your plug-ins, uploads, media files etc. However,… I am tied down with really tight commitments for weeks to come – so I’m desperately hoping that someone else will be able to step up.

    Loggin in through Google Apps login show the same symptoms.

    Daryoush

    (@daryoushashtari)

    I have a web site that has this problem. Here are the things that I did:

    1- deleted all caches
    2- reset .htaccess to default
    3- renamed the plugins directory
    4- renamed the theme directory
    5- set WP_BUG enabled to see any errors
    6- checked all directories and sub-directories for file/directory permission. all were correct: directories: 755 and files: 644
    7- WP table prefixes are all default and lowercase
    8- Table prefix was defined correct and in lowercase in config.php

    Followed ALL instructions in all threads about this issue but I will have this problem. after login, I am redirected to home page and when I manually add /wp-admin to the URL I get the “Sorry, you are not allowed to access this page”

    Tested in PHP: 5.4, 5.5, 5,6 and 7 and still cannot access wp-admin
    WP Version: 4.7.2

    What else I must check?

    What did you CHANGE on the site/server/… before it stopped working? Can you undo that change?

    Did you check the individual records in the wp_options table?

    Daryoush

    (@daryoushashtari)

    WordPress upgraded automatically to latest version from version 4.6. I just noticed that it seems all users that have admin permission, they have lost their admin access and are actually logged in as Woocommerce customer. I checked wp_usermeta for my account permission. it is:

    wp_capabilities a:1:{s:13:”administrator”;b:1;}

    Although it is administrator, but I don’t have admin access. I cannot understand how admin permissions are lost by just an upgrade.

    I have the exact same issue as Daryoush, when I got to /wp-login and log in with admin details, it redirect to home page, if I try go to /wp-admin, I get the error message “Sorry, you are not allowed to access this page.”

    I have not changed anything, or moved servers or changed table names.
    I need to add products to my clients website and edit pages and I can do nothing.

    Any help would be greatly appreciated.

    Thanks.

    @mark3mark I have the same issue, and have had it for ages without finding a cure. You should still be able to access the control panel. Just delete the latter part of the URL (everything after the site name), and you should still be logged in with the menu bar at the top. For me, the only way to get into the control panel is to click the comments icon. You should be taken to you list of comments.

    Me too – I have been trawling the suport forums for clues. I have deleted all my plugins, updated everything that needed updating, deleted everything I didn’t need, reinstalled the latest version of WordPress and still have the same error ‘Sorry, you are not allowed to access this page.’.

    I can only get to the site through my hosting company – GoDaddy.

    Is there anyone at all reading these posts who can give us a definitive solution as I don’t want to live like this.

    Thanks in advance.

    Hi there, I just changed my admin wp_capabilities from a:1:{s:13:”administrator”;b:1;} to a:1:{s:13:”administrator”;s:1:”1″;} and I have access to wp-admin , but not full admin access, (I cant edit menus and create or edit pages, I can post and create/ edit woocommerce products.)
    any ideas? what to try next?
    I really need full access back

    Hey,

    I’m sorry to hear that some of you are still experiencing issues.

    Try checking out this support forum post as there are a couple of fixes later on in the thread that should help: https://wordpress.org/support/topic/wp-admin-sorry-you-are-not-allowed-to-access-this-page-1/

    In short, make sure your database table prefix doesn’t include capital letters and be sure your wp-config.php file also doesn’t list the prefix with capital letters as well. You may need to manually make these modifications.

    Also, be sure your version of PHP is 5.6 or higher. This may be the cause if you see this error on a fresh install of WordPress.

    Good luck! 🙂

    • This reply was modified 2 years, 9 months ago by Jenni McKinnon. Reason: [Edit: I updated the link so it would open on the first page of the thread.]

    @ninianepress That solution comes up in every thread relating to this problem.

    I have looked at every solution suggested in every thread I can find on the topic and so far nothing has fixed the issue. I have

    deleted and deactivated all plugins
    checked and rechecked and reset prefixes in db and wp-config
    checked php version
    checked and reset .htaccess
    created new admin user
    checked wp_capabilities

    So far nothing. I am just glad my whole site hasn’t broken down as it has taken me four years to get to where it is now. To start over is not an option.

    @geirrosset Do you remember what the last thing you did was before you received this error? It’s a long shot since you mentioned this happened ages ago, but I thought I’d ask, anyway.

    – Did you backup, then reset your settings?
    – Did you have a security plugin installed before this issue first occurred?
    – Did you run any security scans to see if there were any issues?
    – Did you check your access logs when it first happened to check for unauthorized access to files or the database?
    – Did you check your file permissions to make sure they’re all set correctly?
    – When did this start happening? What version of WordPress and PHP did you have installed at that time?
    – Do you have any backups saved?
    – did you check your error log when it started happening?
    – Did you try turning on wp_debug with logging?
    – Did you check the _usermeta table for incorrect references to the prefix in the meta_key column?
    – Did you check the _options table for an incorrect reference in the option_name column and _user_roles?

    Trying to gather as much info as I can to see if I can figure something out for you.

    I know you said starting over wasn’t an option, but have you considered exporting your posts, media, users, etc. and importing them to a fresh site? It wouldn’t exactly be starting over from scratch. Just thought I’d throw it out there.

    It’s also a good idea to start a new thread as per the support forum guidelines, especially since all the fixes mentioned here haven’t resolved this for you.

    • This reply was modified 2 years, 9 months ago by Jenni McKinnon. Reason: Added more questions

    Spot-on! Andy Schmidt !!

    Thank you so much!

    @geirrosset Did you manage to solve the problem?? I have the same issue and I have tried EVERYTHING in every other topic in the forum. I still can’t get past the “Sorry, you are not allowed to access this page”.

    Please, if you fixed it, let the community know, as there might be more people with the same problem.

Viewing 15 replies - 31 through 45 (of 59 total)
  • The topic ‘WP ADMIN : Sorry, you are not allowed to access this page’ is closed to new replies.