Support » Fixing WordPress » WP ADMIN : Sorry, you are not allowed to access this page

  • hi iam a newbie with wordpress, and i have been using my wordpress smoothly without any problem for the past few months now, but for like one week now if i log in to my wp-admin it tells me “Sorry, you are not allowed to access this page”… please someone help me with.. i cant access my dashborad

Viewing 15 replies - 16 through 30 (of 59 total)
  • We are experiencing the SSL issue as well, but it is not multisite. When SSL is added to the site, we cannot access wordpress although the frontend of the site works and is live.

    Here are the steps we have taken:
    here is what i did
    1) deactivated plugins
    2) deactivated mu plugins
    3) set to default .htaccess
    4) set home/ and site urls to https
    5) changed theme to default
    6) removed cache
    7) checked debug log for wordpress debug no errors

    The site URL is http://wines-unlimited.ca/

    Thank you, Andy

    That worked for me. I had made the simple mistake of changing MYWP_ to mywp_ so the cause was not obvious.

    In my case, it was a matter of updating the table prefix 🙂

    thanks, @kwscloud, this worked for me.

    iLen

    (@ilenstudio)

    My plugin had the same problem, the error was the language functions __ and _e
    I removed these functions and worked, the message disappeared

    What worked for me was changing wp_2_user_roles to wp_user_roles in wp_options

    geirrosset

    (@geirrosset)

    I still have not found a solution for this. My database has the syd_ prefix so wp_user_roles is named syd_wp_user_roles. Changing this to wp_user_roles removes the error during login, but also removes the top menu after logging in meaning I cant access the dashboard.

    Updates can only be done in the plugin list view or in the theme browser. The updates page is not accessible.

    I am unable to view the summary page after logging in.

    I am unable to enable Jetpack.

    The top left dropdown menu with my site name does not work while viewing the site, but it works when I am on the admin page.

    Tried the “All in one security” plugin to change the db prefix back to the default wp_ to no avail. I still get the same error.

    Andy Schmidt

    (@andy-schmidt)

    geirosset: In cases like this, you have to be very exact with you information because we can’t guess if you are omitting things for convenience or if they are truly missing, thus wrong, in your system.

    What does your your wp-config actually state as the prefix parameter? Because if $table_prefix truly is “syd_” instead of “syd_wp_” then the table names would be “syd_user_roles”, not “syd_wp_user_roles” etc.

    Once you CORRECTLY match up your table prefixes with the wp-config settings, then the NEXT step is to bring this in line with the information in your wp_usermeta table and in your wp_options (or whatever the correct table names are in your system).

    THOSE two tables have records that normally would start with “wp_” (the default table prefix) – so those rows would have to be changed to match whatever correct value to match your ACTUAL table names AND your $table_prefix.

    PS: Also, you didn’t explain when this started breaking? What is that you changed/installed etc. that caused your site to fail for the first time? Why not undo it?

    geirrosset

    (@geirrosset)

    Received an answer from Andy Schmidt via email, but can’t see that post here. I’ll answer him anyway.

    Used “All in one security” to change the table prefix to the default wp_

    Now I have the following:

    $table_prefix = ‘wp_’;

    wp_options->wp_user_roles
    wp_usermeta->wp_capabilities AND wp_user_level

    Still get the same errors.

    Hello, I have the same issue. After i’ve update to wordpress 4.6 and login to Dashboard. But it’s redirect to home page. Then i type myweb.com/dashboard and it’s display – ” ” “Sorry, you are not allowed to access this page.” Please help me soon

    Sorry, you are not allowed to access this page. error msg:when i am acess wp-admin

    Hi, I’m installing a new site from scratch. Installed WordPress, theme and plugins, demo content. Everything OK until the last step of the process: I’m asked to update the database, it’s redirect to homepage and when I try to go to wp-admin I get “Sorry, you are not allowed to access this page.” Please help, I’ve tried this twice with the same result.

    Just wanted to post up that Andy’s answer made the difference for me. If you’re adding users with sql and forget to change the prefix when you’re adding the capabilities you’ll run into this. Thanks Andy.

    @ericstaytrue, glad these hints helped you. It’s an unexpected dependency that trips up people all the time.
    And let me state my apologies to those who still couldn’t make it work and were hoping for one-on-one assistance. Unfortunately, the only way to diagnose this further would be by cross-checking the various references in the live MySQL tables of your system.

    Thanks Andy, you saved my day!

    +1 your hints..

Viewing 15 replies - 16 through 30 (of 59 total)
  • You must be logged in to reply to this topic.