Support » Fixing WordPress » WP ADMIN : Sorry, you are not allowed to access this page

  • calebdenze15

    (@calebdenze15)


    hi iam a newbie with wordpress, and i have been using my wordpress smoothly without any problem for the past few months now, but for like one week now if i log in to my wp-admin it tells me “Sorry, you are not allowed to access this page”… please someone help me with.. i cant access my dashborad

Viewing 15 replies - 1 through 15 (of 59 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

    Hello, I have the same issue. After i’ve update to wordpress 4.6 and login to Dashboard. But it’s redirect to home page. Then i type myweb.com/dashboard and it’s display – ” ” “Sorry, you are not allowed to access this page.” Please help

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    If the above didn’t work for you, please open your own thread: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    If the above didn’t work for you, please open your own thread: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    Moderator t-p

    (@t-p)

    Try:
    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    – If you can’t get into your admin dashboard, try resetting the plugins folder by FTP. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder (if you have created such folder). The easiest way is to rename that folder to mu-plugins-old.
    – switching to the unedited default Theme (Twenty Sixteen, etc.) for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins). If you don’t have access to your admin area, use FTP , or your web-host’s cPanel or whatever file management application your host provides (no Dashboard access required). Navigate to /wp-content/themes/ and switch to the default theme by renaming your current theme’s folder by adding “-old” to the end of the folder name. Alternately, you can remove other themes except the default theme. That will force your site to use it.

    All solutions posted here are not working for me.

    1. In wp_options there is no active_plugins row.
    2. When I changed the plugins folder’s name to plugins.hold or change my current theme’s folder name my site just goes all white/empty.

    Any solutions for this? Thanks!!

    1. Make sure you clear any caching and deactivate any caching or performance plugins. This also includes server caching software like Varnish and hosted solutions such as CDNs such as Cloudflare. After any change you make in the steps below, clear your browser cache.

    2. Start by taking a full backup of your WordPress site, including all files and the database.

    3. Once you have a good backup, deactivate ALL plugins.

    4. If the problem went away then you know it was caused by one of the plugins you deactivated. Reactivate each plugin one at a time until the problem occurs. You now know which plugin is causing your issue.

    5. If the problem does not go away when you have deactivated plugins then switch to the default WordPress theme (currently this is Twenty Sixteen).

    6. If the problem went away then you know it was caused by your theme.
    You can also enable ‘WP_Debug’ and check the debug log for error messages. For instructions on how to do this, please consult the WordPresss Codex.

    7. If none of these resolve the issue, there may be a problem with the settings. Try resetting your settings to the defaults and see if that fixes the problem. But before you do this, you will want to export your settings so you can restore them after testing.

    Cheers.

    I have tried disabling the plugins but I can’t login in wp-admin. Also took it to the next level by reverting to the default theme but I still can’t. The last time I did was updated to latest WP version and updated two plugins and boom this all blew up. 🙁

    EDIT: Found the culprit. It’s Cloudflare’s WordPress plugin. I don’t know what’s wrong with it.

    • This reply was modified 2 years, 10 months ago by  dorelljames.

    Glad you’re back on track.
    happy wordpressing!

    just an fyi for multisiters.

    I had a similar problem when I converted an existing wp installation to a multisite setup.

    Reactivated all the required plugins, and got the same error msg.

    Used James’ method to force a deactivate on all plugins, then reactivated them 1 by 1 to find the culprit.

    Had to apply the method again once the culprit is found, naturally.

    saved me bacon lol, thanks James.

    Although not likely the problem for THIS user, this particular message will occur when someone “consolidates” various WordPress projects into a single MySQL schema, and in the process CHANGES the table prefix in the wp-config and renames the tables to match the new table prefix (e.g. from “wp_…” to “mywp_…”.

    There is a very unexpected dependency of the table prefix in a handful of records in the wp_usermeta table and one in the wp_options. Fortunately, it’s very easy to fix. Just look for a key starting with “wp_” (the default table prefix) and then change those rows to the keys matching the new table prefix in your wp-config, e.g. “mywp_”.

    Basically, your “admin” user has “login” permission, but those records in wp_usermeta and wp_options are the ones that give that logged-in user permission to manipulate the data stored in a particular set of tables. It’s likely a carry-over from the MultiSite implementation.

    I have the same problem. Started a short while ago. Suspect around the time I updated WP. I have deactivated all plugins. And looked for database keys with he wrong prefix, but couldn’t find any.

    At the moment, by using history in my browser to go back to a logged in session (how does this work?) I can create new posts, and edit existing posts, but I cannot log in though wp_admin, edit users, or access the update page.

    Thanks, this worked for me. Easy to miss the wp_options one since it’s on line 80 something.

    In my case I had installed Frontier Restrict Media plugin so that each user can only access their own media files.
    That plugin i deactivated and bbpress started working fine

    After updating multisite to 4.7 a couple of days ago I had these issues ie/ locked out, no password reset option, etc. I tried numerous methods to see if the password had been reset and stuff.
    After reading this and another similar post in the forums I decided to try the core of what is mentioned here.
    Logged into wordpress using ssh via winSCP (win10 freeware tool)
    Change the folder plugins' tohold-plugins’
    Logged in to WP using same username and pswd as before it broke (succesfully)
    Renamed hold-plugins' back toplugins’
    logged out and then back into WP
    All plugins were there but required re-activating (some due for updates)
    re-activated and logged out a few plugins at a time.
    EVERYTHING IS FINE NOW – I left some plugins de-activated because they are not used and set email to smpt to my zoho email account (tested and works)
    all up – 1/2 hour.
    just in case it starts a lot with the 4.7 update (esp multisite)

Viewing 15 replies - 1 through 15 (of 59 total)
  • The topic ‘WP ADMIN : Sorry, you are not allowed to access this page’ is closed to new replies.