Support » Requests and Feedback » wp-admin slow because of execute-pings.php

wp-admin slow because of execute-pings.php

  • I’ve just noticed that in the admin interface (wp-admin) there is in each page this part at the end of the page:

    <iframe id=”pingcheck” src=”http://readmaniac.pbworks.net/wp-admin/execute-pings.php?time=1149590406″ style=”border:none;width:1px;height:1px;”></iframe>

    execute-pings.php slows down each admin page.

    Wouldn’t it be better to ping the update services only after an article is written? Or give the admin also the option to ping manually?

    I think it’s a bug also the fact that the execute-pings.php is called (and slows down my site) even if I have no update service configured (I got rid of the pingmatic server).

    The only way I found to make the admin interface fast as it is supposed to be was to adblock the url /wp-admin/execute-pings.php

Viewing 4 replies - 1 through 4 (of 4 total)
  • There is a plugin to help with theis, it’s called Smart Update Pinger. Can’t remember the link, but it’s on Google 😉

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    execute-pings doesn’t have anything to do with the Update Services (like pingomatic). It’s pinging URLs you link to in your posts (aka pingbacks). And it’s only slow because you have a lot of URLs left to ping. Once it finishes pinging those URLs, it doesn’t have anything else left to do.

    The whole point of making that hidden iframe is so that the pingbacks can execute in the background.

    Otto42, thanks for your explanation.

    Anyway I experienced problems even if it’s an iframe loading at the end (in my blog+browser combination -firefox it is not working as expeced: when editing a post the tinymce menu took too much time to load, like 20 seconds or so…).

    I was thinking that the update sercives where the servers to ping (pingback)…

    Is it possible to deactivate pingbacks? If yes, how?

    It’s definately in your options, you just have to look for it 😉 Try the “Write” section.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wp-admin slow because of execute-pings.php’ is closed to new replies.