Support » Plugin: WP Cerber Security, Anti-spam & Malware Scan » Wp-admin redirects to login page

  • Hi

    I have checked that my settings are correct, but /wp-admin still redirects to my custom login page.

    I have ruled out plugin and theme incompatibilities.

    What else can I try?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Gregory

    (@gioni)

    Hi!

    Could you test and reproduce that behavior in a different browser and on a different computer?

    Thread Starter Design by Think

    (@minki-pool)

    Hi

    I have tried it from 2 different computers and on my Android phone. Browsers I have tried include Firefox, Chrome, Safari and Opera.

    I have also removed our IP from the white list.

    /wp-admin keeps redirecting to the custom login page.

    I am also experiencing this with one of my WordPress instances. wp-login.php returns a 404, but if I access wp-admin it redirects to my custom login page. My IP is not in the access/whitelist.

    Thread Starter Design by Think

    (@minki-pool)

    Hi

    Has there been any progress on this?

    Hey @minki-pool

    I actually just figured this out, it’s a strange settings issue.

    Along with restricting access to wp-login.php and setting a custom login page. You also have to check off under Proactive security rules “Disable automatic redirecting to the login page when /wp-admin/ is requested by an unauthorized request”

    It seems redundant, because if you want to blog wp-login, you sure as shit want to block wp-admin and instead use the custom URL. Without this, intruders accessing wp-admin are simply redirected to your secret (or so you thought) login URL.

    Thread Starter Design by Think

    (@minki-pool)

    Hi @colewebdev

    Thanks for letting me know! I have actually already tried that. Still no luck. 🙁

    I am having the same issue as Design by Trick. All proactive security rules are checked, custom login page is enabled and the “disable wp-login.php” is checked. However, wp-admin is redirected to the custom login page. login-php is blocked and works as it should.

    I have the same exact configuration for another website, and it’s working as it should but for this one website, wp-admin is being redirected to the custom page.

    I have checked the .htaccess file and except for the begin wordpress entry

    Any suggestions?

    Thank you for your support.

    Oops I take it back. Cleared the cache and now wp-admin page no longer redirects to the custom login page. So it’s working for me after clearing cache.

    Thank you for your time!

    Plugin Author Gregory

    (@gioni)

    Hi @minki-pool!

    How is it going?

    Hi!

    Having the same/similar issue with @minki-pool
    I’ve tested this extensively tried on incognito or clean browser on mobile and desktop (multiple devices/OS, multiple browsers) and IPs not whitelisted and whitelisted. Cache has been flushed.
    Basically for some devices it 404 (page not found) which is great!
    But for some they do the redirect to the ‘secret’ login page link (which discloses the URL) when you hit /wp-admin and appends this URL param: ?redirect_to=https%3A%2F%2Fwww.XXXX.com%2Fcms%2Fwp-admin%2F&reauth=1

    Thanks

    “You also have to check off under Proactive security rules “Disable automatic redirecting to the login page when /wp-admin/ is requested by an unauthorized request””

    @colewebdev Where can I find this?

    Plugin Author Gregory

    (@gioni)

    @dashacphotography On the Main Settings plugin admin page.

    Thank you @josiah – had same issue, now resolved.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Wp-admin redirects to login page’ is closed to new replies.