Support » Fixing WordPress » wp-admin redirects on multi-network

  • Resolved wlpdrpat

    (@wlpdrpat)


    Hi,

    I have a multi-network setup. I was changing the network activated plugins on one of the networks. Specifically, I was deactivating several plugins that were network activated for testing purposes. I selected the plugins to deactivate and used the drop down Network Deactivate function.

    As it completed deactivating the plugins I was redirected to the homepage of the primary network. Since then I can not access any wp-admin or network admin pages. When I try to access any of them I am redirected to the primary network homepage.

    Additionally, the primary network homepage is broken (no css or js is rendering).

    I am quite good at debugging and would consider myself an advanced user but this one has me stumped.

    Fortunately, I do have api access to be able to activate/deactivate plugins on all the networks. I have tried restoring the original plugin configuration (activating the ones that I deactivated) but no dice.

    My gut says something was changed in wp-config but my eyes are not seeing it.

    Any thoughts or ideas would be appreciated.

    Pat

Viewing 1 replies (of 1 total)
  • wlpdrpat

    (@wlpdrpat)

    I found the problem.

    When I deactivate the plugins – one of them was Really Simple SSL which tried to make changes to the wp-config and htaccess. The changes to the htaccess failed and caused the htaccess to get locked by my security plugin. When I reviewed the content of htaccess it looked perfect. However, the solution was to restore the htaccess to remove the lock.

    Se la vie – 5 hours of debugging and all I had to do was restore the .htaccess

    Whew!!

Viewing 1 replies (of 1 total)
  • The topic ‘wp-admin redirects on multi-network’ is closed to new replies.