Support » Fixing WordPress » WP Admin login

  • I am trying to log into my site [ redundant link removed ]

    The login details that I previously used are not working and the email address to recover my password states not valid.

    Any thoughts please?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • The best way to update your user password would be at the database level, if your login and email/forgot password are not working.

    Assuming you’re using cpanel/phpmyadmin:

    1. Access phpmyadmin
    2. Click on the table wp_users
    3. Edit the row with your WordPress account username
    4. In the user_pass field, change the Function to MD5 and enter your new password in the Value section
    5. Click the “Go” button

    Now, return to your login screen and try logging in with your username and new password.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Side note: @judgerookie The site you linked to? That company earned a permanent ban in these forums. Please do not link to them again.

    I can’t log on to wp-admin. When I try, I get this:

    Deprecated: __autoload() is deprecated, use spl_autoload_register() instead in /home/deborahg/public_html/wp-includes/compat.php on line 502

    Warning: Cannot modify header information – headers already sent by (output started at /home/deborahg/public_html/wp-includes/compat.php:502) in /home/deborahg/public_html/wp-includes/pluggable.php on line 1210

    I’ve tried to update my site, and I get a series of error occurred messages that prevent me from updating. Also, in front of my url, it says my site is not secure.

    These are only warnings; you can turn these off by setting wp_debug to ‘false’ (in the wp-config.php file). This should look like:

    define( 'WP_DEBUG', false );

    Are you able to login, and when you do, you’re seeing these errors AND the WordPress backend area as expected (and you’re just looking for ways to remove these errors)? Or, are you not able to login at all?

    After you’re able to login successfully, you can reactivate wp_debug and look into resolving the issues referenced in those error messages (and the suggestions conveniently provide the specific issues to review and the corresponding line numbers in the actual code). But, I would not work on these updates on the live site — these updates should be done in a staging environment that you can test, confirm issues are resolved, and then push the updated code to your live site.

    My recommendation would be to turn wp_debug off, confirm your login is working and site is functioning as expected. Then, make a full backup of your site, use it to spin up a staging site that you can work with to make changes without risking performance on your live site, and after the site is updated and again working the way you want, disable wp_debug and migrate the updated version to replace the currently live version.

    For the “site not secure” warning, I am also seeing this. This is only because your site is currently loading without https, without an SSL set up and installed. There are a variety of ways to update this.

    Here is a nice step-by-step walkthrough for moving your WordPress site from http to https:

    HTTPS for WordPress

    I also see your site is hosted at 1&1 hosting, here is some specific information from your host regarding SSL and how to set this up on their servers:

    https://www.ionos.com/digitalguide/websites/website-creation/how-do-i-convert-my-site-to-ssl-and-https/

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP Admin login’ is closed to new replies.