Support » Plugin: WP Cloudflare Super Page Cache » WP Admin Is being cached.

  • Resolved Arnab Mohapatra

    (@arnab0207)


    Hey!

    Thanks for the neat plugin tested with the Nginx server with the custom server block provided by the plugin it worked fine without any problems. However, I am facing problem with getting it to work with the Litespeed server. My WP-Admin is being cached in cf. I tried replicating the same with other websites and hosts the same problem.

    Here are few videos showing the issue-
    1) https://d.pr/v/Ixwacw
    2) https://d.pr/v/Mrqk6R

    This is the cache header

    age: 8
    alt-svc: h3-27=":443"; ma=86400
    cache-control: s-max-age=604800, s-maxage=604800, max-age=60
    cf-cache-status: HIT
    cf-ray: 5a1da2e78bdce12d-BOM
    cf-request-id: 03466424b00000e12dd7844200000001
    content-encoding: br
    content-type: text/html; charset=UTF-8
    date: Thu, 11 Jun 2020 19:11:10 GMT
    expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
    referrer-policy: strict-origin-when-cross-origin
    server: cloudflare
    status: 200
    strict-transport-security: max-age=15552000; preload
    vary: Accept-Encoding
    x-frame-options: SAMEORIGIN
    x-litespeed-cache-control: no-cache
    x-wp-cf-super-cache: no-cache
    x-wp-cf-super-cache-cache-control: no-store, no-cache, must-revalidate, max-age=0
Viewing 6 replies - 1 through 6 (of 6 total)
  • Same problem here. My hosting has Litespeed webserver and whole admin is cached by CF. Had to add a page rule in CF to fix this. (*domain.com/wp-admin/* Cache Level: Bypass)

    It would be nice if the plugin take cares of this.

    Thank you very much for making this plugin though. 🙂

    • This reply was modified 1 year, 7 months ago by Greyleg.
    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hello guys,
    the plugin works with Litespeed Server but there is currently a problem when used in conjunction with other caching plugins.

    This happens because most of these plugins set their own cache-control header for HTML pages and this is not acceptable as it interferes with the Cloudflare cache.

    On Apache I solved it by inserting in the htaccess file a rule of mod_headers that overwrites this header (option Overwrite the cache-control header for WordPress’s pages using web server rules) with the one set on my plugin but on Litespeed server this rule does not work.

    I contacted the Litespeed development team and they confirmed that, although the syntax conforms to mod_headers, they do not support the expression expr = value which in this case is necessary because the header is overwritten only on precise conditions dictated by my plugin through a custom header. In their case, the cache-control is always overwritten, also caching pages that should not be inserted. And this is not acceptable.

    Of course the plugin understands if you are using Litespeed Server and informs you of this.

    On upcoming version of the plugin I will add an option to use cloudflare workers and thanks to this the litespeed support will be full.

    I am also working on a pro version. Give me a few more days and you will all be updated 😉

    Thread Starter Arnab Mohapatra

    (@arnab0207)

    Hi @salvatorefresta

    Thanks for your input. I disabled caching from LS Cache ( https://d.pr/i/Ow7Vwp )

    Still, wp-admin pages are being cached. ( https://d.pr/i/fPh3Cv ) am I doing something wrong?

    Current cache headers-

    age: 210
    alt-svc: h3-27=":443"; ma=86400
    cache-control: s-max-age=604800, s-maxage=604800, max-age=60
    cf-cache-status: HIT
    cf-ray: 5a242d7d38e90000-SIN
    cf-request-id: 034a7ac23e000100d317a26200000001
    content-encoding: br
    content-type: text/html; charset=UTF-8
    date: Fri, 12 Jun 2020 14:14:21 GMT
    expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
    referrer-policy: strict-origin-when-cross-origin
    server: cloudflare
    status: 200
    strict-transport-security: max-age=15552000; preload
    vary: Accept-Encoding
    x-frame-options: SAMEORIGIN
    x-wp-cf-super-cache: no-cache
    x-wp-cf-super-cache-cache-control: no-store, no-cache, must-revalidate, max-age=0
    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @arnab0207 ,
    are you disabled the option Overwrite the cache-control header for WordPress’s pages using web server rules before to purge the cache?

    I see a correct x-wp-cf-super-cache response header but a different cache-control value than x-wp-cf-super-cache-cache-control (there headers must be the same).

    If yes, please paste here your htaccess

    Thread Starter Arnab Mohapatra

    (@arnab0207)

    Hi @salvatorefresta
    Hope you are having great weekend.

    Thanks that worked.

    However, I ended up settling with this plugin https://wordpress.org/plugins/wp-cloudflare-cache/

    it invalids caches properly when logged in when LS caching is active. Letting you know if you can implement a similar setup in your plugin!

    Thanks again
    Arnab

    Plugin Author Salvatore Fresta

    (@salvatorefresta)

    Hi @arnab0207 ,
    the plugin you linked above only adds/removes a cache-control header on template_redirect WordPress hook for logged in users. This features is only a very small part of my plugin.

    So you can obtain the same behavior by disabling the option Overwrite the cache-control header for WordPress’s pages using web server rules that is not compatible with litespeed server due to an incorrect implementation of the mod_headers rules by their development team.

    Just 1 click to disable a default enabled option.

    Have a nice day 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP Admin Is being cached.’ is closed to new replies.