Support » Plugin: Opt-Out for Google Analytics (DSGVO / GDPR) » wp-admin/includes/upgrade.php triggers htaccess changes

  • Resolved danielrufde

    (@danielrufde)


    It seems you require wp-admin/includes/upgrade.php at https://plugins.trac.wordpress.org/browser/opt-out-for-google-analytics/trunk/inc/activator.class.php#L6 which produces some issues.

    For example when some bots like Bing bot and others visit pages of the website, this gets executed and the upgrade scripts run flush_rewrite_rules($hard = true) which overwrites / changes the .htaccess file which might look like some suspicious changes due to some hack or similar but the content (the language of the comments) just switches between the locale of the current / last visitor.

    I guess you forgot to move this line to the correct place or remove it completely.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.