Support » Fixing WordPress » WP Admin GUI broken after backup/restore

  • I wanted to update WP to version 3.0.4 and read the “before you’s…”

    Having made a backup of both content and db’s, I deleted my site and restored it from local backups.

    The public pages all seem to be intact (my site is still in it’s infancy and there’s not a great deal of content yet). However, when entering wp-admin and using the GUI’s to carry on adding content to my site, I noticed that the ‘edit pages’ GUI is broken.
    The ‘visual pane’ has content but it’s all white/invisble, clicking the ‘html’ tab shows the html code and when clicking back to ‘visual’ the html code remains visible.

    There may be other breakages that I am not aware of yet.

    As for a bit of background to the saga…

    • My hosting service is through 000webhost.
    • I was unable to execute an automated update of WP, as they have turned off ‘name resolution’ on their server due to a separate issue.
    • I was unable to use their backup tools as I could not access the resulting tar.gz files produced by the tool for the content and the db’s… another ongoing issue.
    • I had to manually download the content and the db’s using FTP and phpMyAdmin.
    • Once these files were local, I zipped them, ready for re-upload.
    • 000webhost’s cp tools “1 click website restore” and “1 click db restore” are supposed to enable you to choose a local archive in .zip/tar.gz formats to upload to the host, where they are automatically decompressed and installed… neither of these worked!
    • In the end, I had to resort to manually importing the db backup through phpMyAdmin, and manually transferring the ‘unzipped’ “public_html” via FTP (Fetch).
    • This manual operation seems to have broken the wp-admin somehow… likely through mangling the permissions and ownership settings of each file.

    How should I proceed?


Viewing 5 replies - 1 through 5 (of 5 total)
  • Ok, no responses so far…

    Here’s what I’ve done to try and resolve this:

    I completely cleared my hosting server of all files.
    I reset the account using the host’s cp.
    This gave me a brand new ‘public_html’ directory.
    After downloading WP 3.0.2, I manually ftp’d this to the host (the auto installer won’t work on my host).
    I then manually ftp’d the “wp-content” folder from my local backup to replace the one included with WP 3.0.2.
    I created a new mySQL user and wp database.
    Then I modified wp-config.php to access mySQL db.
    Finally, I imported the db tables from my local backup into my new wp db on the host, using phpMyAdmin.

    The site appears fine… as it should be.
    However, the wp-admin/edit pages utility window is still broken – same problem as before!

    So, something in the ‘wp-content’ directory or within the ‘wp database’ is causing a problem, but I don’t know what and I obviously want to sift it out so that I can retain all of the content changes that are relevant to my site.

    Can anyone help shed some light please?


    I would check permissions. If you have done a restore it might be that the new directories are not set the same as your last setup.

    File permissions

    As your main site works I would assume the DB connection is fine. Often older plugins/themes can cause problems so check nothing can affect you my renaming plugin foldes, and try the twentyten theme.

    Before updating to 3.0.2, I tried an “as is” backup and restore, using the exact files and db that comprised my ‘working’ site and dashboard/wp-admin.

    So, it would seem to point towards permissions, as you say. I did notice that when first ftp’ing my public_html directory from the host and then ftp’ing it back for a restore, the permission had changed on that from what it was previously, so I’ll look into what other directories may have been altered. BTW, is the a way to d/load files from the host and ensuring that permission don’t get altered?

    Also, my host has a tool in the cp for fixing permissions. Do you think it would be safe to use this?

    Ta, Deano.

    Permissions are often defaults on servers, depending on the host. It won’t be the download that alters them, it will be the upload back again. for example, some hosts will allow 777 some will only allow 775 when uploading.

    I don’t personally know of a way to keep permissions when running through control panels, with direct unix commands from an admin user it is different.

    I would think that if your host is supplying a tool to change permissions it should be fine – though I have to use the usual disclaimer here, I can’t say for certain as I didn’t write it/never used it so don’t blame me if it doesn’t! However, it should be OK.

    As to the permissions issues within WP (if that is what you meant) if you follow the permissions they state then you should be OK. I have found that there is some ‘flexibility’ around permissions however, third party software can sometimes be a pain especially if file uploads are required.

    Thanks for the help.
    I have to fess up now…

    After trying this fix this and that, looking at permissions and using the cp tools, the problem still persisted.

    Then a moment of clarity and a resort back to the step-by-step debugging that I should have employed in the first place… “check local environment for issues first!”

    A quick login from my other laptop to my site and all was working in the admin tools! Back to my laptop>open Safari>Empty Cache and all is now working fine on here too!

    Obviously a bad cookie or hinky in the cached pages… I should have recalled from my early days building sites from the ground up… pre WordPress et al.

    So, let this be a lesson to others… check both environments!

    Thanks again for the info and the links.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP Admin GUI broken after backup/restore’ is closed to new replies.