Support » Fixing WordPress » Wp-admin Error 500 message

  • I had wp working.

    The host doesn’t seem to have an “error log.” I have asked them for the location.

    1. Does anyone here speak this stuff:

    MySQL – 5.0.45-log
    MySQL charset: UTF-8 Unicode (utf8)
    MySQL connection collation: Collation
    Show MySQL runtime information
    Show MySQL system variables
    Show processes
    Character Sets and Collations
    Storage Engines

    phpMyAdmin –
    Used PHP extensions: mysql
    Theme / Style: Darkblue/orangeOriginal
    phpMyAdmin documentation
    Official phpMyAdmin Homepage
    [ChangeLog] [CVS] [Lists]

    Open new phpMyAdmin window

    Anything there that could help me help you figure out why a software suddenly stops working?

    2. They changed setting:

    The short answer is “nothing.” You should not need to update any paths, and your scripts should continue to function as they do now. Still, there *are* some changes you should be aware of:

    The new configuration adopts the more traditional (numeric) method of handling Unix file/directory permissions, and as a result, we’ve set permissions for customers’ home directories to be 750. With this permissions setting, your scripts should continue to run as they always have, and it ensures that others won’t have “write” access to your files.

    Please note: If you change your home directory permissions settings to something other than 750, you may be unintentionally giving others access to change or update your files. There are certain permissions settings that could potentially constitute a security risk (examples include 666 or 777). To protect all of our customers, scripts will not execute if permissions are changed to certain settings (such as 666 or 777).

    One final note: If you use the /tmp directory for temporary files, you will no longer be able to do so. You can, of course, place temporary files anywhere you’d like within your home directory.

    – 01/09/08 at 17:34 EDT

    “To protect all of our customers, scripts will not execute if permissions are changed to certain settings (such as 666 or 777).”

    Could this be the problem? If they change it to 750 and wp won’t run with this do I have any options beside getting another host? What if all hosts adopt this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • I had the same error and it seemed to get fixed by editing my .htaccess file to make it compatible with php5.

    I use 1and1 as a host and I guess the upgrade blew away my .htaccess file

    I put the following in the file:
    AddType x-mapp-php5 .php

    and this made it work….

    raymond’s solution also worked for me!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Wp-admin Error 500 message’ is closed to new replies.