Support » Networking WordPress » wp-admin diverts to public_html/wp-admin

Viewing 5 replies - 1 through 5 (of 5 total)
  • What’s in your wp-config.php? Is there a second base path listed?

    I have no idea what I’m looking for in the wp-config file… can you elaborate a little please?

    Here’s some of the crap… I mean what I’ve got in there (I’ve bla bla bla’d passwords & stuff):

    /** The name of the database for WordPress */
    define ('WP_CACHE','true');
    define('DB_NAME', 'allthing_wpmu');
    /** MySQL database username */
    define('DB_USER', 'bla bla bla');
    /** MySQL database password */
    define('DB_PASSWORD', 'bla bla bla');
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', '' );
    define('PATH_CURRENT_SITE', '/' );
    define('BLOGID_CURRENT_SITE', '1' );
     * Authentication Unique Keys.
     * Change these to different unique phrases!
     * You can generate these using the {@link secret-key service}
     * @since 2.6.0
    define('AUTH_KEY', 'bla bla bla');
    define('SECURE_AUTH_KEY', 'bla bla bla');
    define('LOGGED_IN_KEY', 'bla bla bla');
    define('NONCE_KEY', 'bla bla bla');
    define('AUTH_SALT', 'bla bla bla');
    define('LOGGED_IN_SALT', 'bla bla bla');
    define('SECURE_AUTH_SALT', 'bla bla bla');
     * WordPress Database Table prefix.
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
    $table_prefix  = 'wp_';
     * WordPress Localized Language, defaults to English.
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
    define ('WPLANG', '');
    // double check $base
    if( $base == 'BASE' )
            die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    // uncomment this to enable wp-content/sunrise.php support
    define( 'SUNRISE', 'on' );
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    //define( "UPLOADBLOGSDIR", "fileserver" );
    //define( "UPLOADS", "files" );
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to for the following: define( 'NOBLOGREDIRECT', '' );
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you can use the 404 handler.
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    // Uncomment to disable the site admin bar
    //define( 'NOADMINBAR', 1 );
    define( "WP_USE_MULTIPLE_DB", false );
    define( 'NONCE_SALT', 'bla bla bla' );
    /* That's all, stop editing! Happy blogging. */
    /** WordPress absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
             define('ABSPATH', dirname(__FILE__) . '/');
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Okay, look in your .htaccess for any calls to public_html

    (also? Cookies for knowing to hide your nonces and salts!)

    I can’t find public_html anywhere in .htaccess – any other ideas?

    LOL I just hid anything that looked passwordish

    Turn off all your plugins. Nothing in WP itself would do that redirect.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘wp-admin diverts to public_html/wp-admin’ is closed to new replies.