Support » Fixing WordPress » Wp-admin blank page

  • amamam


    HI all,

    I can see all the pages online of my blog but i cannot visualize the wp-admin section that is completely blank…

    Someone knows hot to fix that problem?

Viewing 14 replies - 1 through 14 (of 14 total)
  • issy-m


    take a look at your functions.php file and make sure the are NO spaces at the top or bottom.

    I had the same issue, I was not able to login to my wp-admin section and this fixed it.


    Thanks it works

    Thank you so much. thought i was going to lose my hair as i tried the usual suspects: e.x. renaming plug-ins, removing speces in wp-settings.php, etc.

    FYI. this happened after upgrading to 2.8.1 and editing functions.php in the theme editor.

    I have the same problem after upgrading from 2.7 to 2.8.2

    Do you mean the functions.php file located in the wp-includes folder?

    I did find that there was one line space at the bottom of the file after the closing tag so I deleted the space.

    This was the closing tag:


    However, I am still not able to access the admin page, just getting a blank white page still.

    I just ran into the same problem in 2.8.2 – everything was working fine, then – poof – white screen of death when I try to access the WordPress dashboard. Blog site appears to be fine.

    Weird part is that I made no changes – not even a new post between the time the dashboard was working fine and when it disappeared.

    Have tried all troubleshooting steps, and like Dave333, nothing is working…

    Anyone else with this issue? Anyone with some further insight?

    Two such cases I came across were because of incomplete file over-writing. Try deleting wp-admin folder and upload it over again through FTP.


    I tried editing functions, re-uploading functions – no go. Tried deleting wp-admin, re-uploading. Also tried renaming the plugins folder and creating a new empty one, in case it was a bad plugin. And deleting wp-includes and re-uploading. All to no avail.

    It HAD been working until after 2.8.4 – and during some of 2.8.4 as well.

    I also tried repairing the MySQL database.

    The problem appears to be in auth_redirect, if I put in a comment in admin.php it shows up until after auth_redirect. The page is still blank but adding ?>Hello<? to a line before auth_redirect shows it on the page, and after – it’s gone.

    Also tried deleting .htaccess

    Found the problem:

    1) Set define(‘WP_CACHE in wp-config to false
    2) Delete extra space at the end of wp-config

    I have NO idea why this worked.

    Thx issy-m

    It works


    Ok you guys, I’ve tried everything you’ve posted and still a no-go.

    Here’s what I’ve tried:
    1) deleting extra spaces in wp-admin/admin-functions.php
    2) deleting spaces in wp-content/themes/[mytheme]/functions.php
    3) deleting spaces in wp-includes/functions.php, functions.wp-scripts.php, and functions.wp-styles.php
    4) looked for define(WP-CACHE in wp-config but I didn’t find that line anywhere
    5) backed up the whole wp-admin folder, deleted it from FTP, re-uploaded

    …still no luck. Any other ideas? Like others who have posted, it was working perfectly fine yesterday, no problems, then tried to open it this morning and… nothing.

    Ok, it seems to be fixed. In case anyone else runs across this problem, here is what I did:

    I did a little further detective work and checked the cgi_error_log in the “stats” folder from my FTP site. In looking at that file, I found the line:

    PHP Warning: Cannot modify header information – headers already sent by (output started at /[server info]/wp-config.php:77) in [more server info]

    This was repeated over and over again, so obviously the error had to be in the wp-config.php file, which I had already checked for blank spaces.

    It didn’t have any blank spaces, but it had this random, long <script> at the end of all the regular php info. Wondering what would happen if I removed it and figuring I could always put it back later if I needed to, I erased the script and re-uploaded the wp-config.php file.

    Worked like a charm!

    I had the same problem, and deleted two spaces at the bottom of root/wp-config.php and it cleared up the problem.

    Thanks issy-m

    It worked.

    I deleted blank spaces at the top and bottom of functions.php in my theme folder…

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Wp-admin blank page’ is closed to new replies.