[resolved] wp-admin 404 error after upgrading to 2.6.1 (8 posts)

  1. dgibsonky
    Posted 7 years ago #

    My site is http://www.darrengibson.org . Everything was fine with my installation until I upgraded to 2.6.1. Now, everything "front end" wise is fine (content is available, categories are browsable, etc.), but when I attempt to access http://www.darrengibson.org/wp-admin (or /wpadmin/index.php or /wpadmin/upgrade.php etc.) I get a 404 error.

    I have verified that the folder and its contents exist on my server, and have re-uploaded a few times. I worked through a few similar posts here with no luck. I cleared my browser's cookie cache. I even downgraded back to 2.5.1 with no change. I'm now back to 2.6.1 and in the same boat--the "read" functions work just fine, but I can't log in to the admin panel. Does anyone have any ideas as to what might be the issue?


  2. stephreill
    Posted 7 years ago #

    I have been getting the error message you don't have sufficient permissons after upgrading to 2.6.1 and cannot administer my blog. Any ideas?

  3. vietknight
    Posted 7 years ago #

    Are you sure your folder names are correct?

    I would recommend some consistency in organizing your WP folders/files.

    If all your folders are "wp-[name]" then keep them that way, if they are "wp[name]" then you should also keep them that way. There is no way you can access your admin panel if your folder is "wp-admin" and you type in "wpadmin".

    Secondly, once you figure that out, try pointing to the corresponding place, aka, if your folders start with "wp-" then go to these:


    You cannot have a mix of "wp" and "wp-" folders unless you really want to screw with wordpress to achieve that.

  4. Samuel B

    Posted 7 years ago #

    Your site url's are incorrect. One is for wordpress.org. The 2 url's in "Settings" must be actual url's of your site where your files are located.
    Follow this to change them to correct values.

  5. dgibsonky
    Posted 7 years ago #

    vietknight, all folders are named wp-[name] and weren't changed from the original file structure. The missing hyphens in my original post were typos made in my haste to get it all down before I forgot something. :)

    samboll, thanks for the further info. I went through the steps described in your link and unfortunately had no success. Just to be sure, I checked in the database itself and both "siteurl" and "home" are listed as "http://www.darrengibson.org."

  6. Samuel B

    Posted 7 years ago #

    Is it possible then that index.php is not enabled for folders?

  7. dgibsonky
    Posted 7 years ago #

    I suppose it's possible, but everything was fine before I made the upgrade. I can't imagine there being anything in the installation tarball that would cause such a thing! I'm wondering about the CHMOD permissions for the file folders themselves...perhaps they got bamboozled on transfer somehow?

  8. dgibsonky
    Posted 7 years ago #

    That was it...I feel like a dunce. I know I checked permissions on the files themselves a dozen times, but I guess I never checked the wp-admin folder. It was set to 711 instead of 755. Please consider this "solved" and thank you very much for your patience with my boneheadedness!

Topic Closed

This topic has been closed to new replies.

About this Topic