Support » Plugin: Tainacan » /wp-acervoac/wp-json/tainacan/v2/metadata/ erro 404

  • Ao tentar acessar “Filtros de repositório” retorna o erro de log:

    “GET /wp-xxx/wp-json/tainacan/v2/exporters/available HTTP/1.1” 404 188 “http://localhost/wp-xxx/wp-admin/admin.php?page=tainacan_admin” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.114 Safari/537.36”

    Não completa conexão e fica em lopping, não há restrição de acesso a internet.
    Poderiam ajudar?
    Versão WordPress 5.7
    Versão Tainacan: 0.17.4

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mateus Machado Luna

    (@wetah)

    Olá @etcunha. Pode verificar se os seus permalinks estão ok?

    Vá no painel Administrativo -> Configurações -> Links Permanentes. Lá, marque a opção “Nome do Post” e clique em “Salvar Alterações”, mesmo se já estiver marcado com este valor.

    Recarregue a página e diga pra gente se o erro persiste.

    Thread Starter etcunha

    (@etcunha)

    Olá Mateus,

    Embora não relatei anteriormente mas já havia efetuado este procedimento e de nada adiantou.

    Grato pelo retorno.

    Plugin Author vnmedeiros

    (@vnmedeiros)

    bom dia, @etcunha
    O erro 404 está acontecendo nesses dois endpoints somente, ou em mais algum lugar?

    /wp-xxx/wp-json/tainacan/v2/exporters/available HTTP/1.1
    /wp-acervoac/wp-json/tainacan/v2/metadata/

    No seu servidor você está com o “mod_rewrite” está ativo?

    Att!

    Thread Starter etcunha

    (@etcunha)

    Boa tarde @vnmedeiros,

    Até onde saiba apenas nesses endpoints.
    Por gentileza como faço para verificar o “mod_rewrite”?

    Plugin Author vnmedeiros

    (@vnmedeiros)

    Bom dia,
    se você utiliza algum serviço de hospedagem compartilhada no painel deles devem ter alguma configuração que mostre a situação do “mod_rewrite”.
    Ou você simplesmente também pode fazer um aquivo PHP na raiz do seu site com o conteúdo:

    <?php 
    phpinfo();

    e verificar os módulos instalados e ativos no seu servidor.

    Outro detalhe, seu site está hospedado em um subdiretório? Tem que verificar se as regras de acesso a esse subdiretório estão funcionando bem. Seria mais aconselhável utilizar um subdomínio para acessar a instalação.

    • This reply was modified 5 months ago by vnmedeiros.
    Thread Starter etcunha

    (@etcunha)

    Bom dia,
    Eu tenho acesso direto ao servidor, pelo arquivo info.php não foi encontrado nada referente ao “mod_rewrite”.
    Já verifiquei os direitos de acesso aos diretórios bem como seus owners, estão de acordo.
    Grato.

    Plugin Author vnmedeiros

    (@vnmedeiros)

    bom dia,
    bem provável então que o “mod_rewrite” esteja desligado, isso é uma configuração referente ao servidor que você utiliza, no apache por exemplo:
    http://devfuria.com.br/linux/apache-habilitar-mod_rewrite-no-apache-mod/

    att!

    Thread Starter etcunha

    (@etcunha)

    Bom dia Vnmedeiros
    O servidor utiliza nginx mas irei pesquisar, muito obrigado.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.