Support » Plugin: MailChimp Campaigns » WP 5 compliancy

  • Resolved agencecoccinet

    (@agencecoccinet)


    Hello!

    Thank you for your great module – it’s been working great on our website for a while.

    Unfortunately, since we upgraded to WP 5 (currently 5.0.3) we are not able to import latest Mailchimp campaigns.

    I was just wondering if you have a plan to publish a new version of the extension?

    Thank you in advance for your answer!

    Regards,
    Max

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author matthieuscarset

    (@matthieuscarset-1)

    Hi @agencecoccinet
    Thanks for using this plugin.

    I do have plan to upgrade it… unfortunately I do not have much time available for this project.

    Hopefully I can work on it again soon.

    I will notify everyone in this forum asap for sure.

    arjunmr

    (@arjunmr)

    Hey Matthieu

    This plugin is great and is critical for our website project. We have been able to pull Mailchimp campaigns as WP Posts all along using your plugin. However after upgrading to WP latest version it gets stuck forever at the importing campaigns page, but actually doesn’t pull anything. Would you please check and fix this? If you were to monetize this plugin I would be more than happy to contribute.

    Thanks!
    Arjun

    Plugin Author matthieuscarset

    (@matthieuscarset-1)

    Hi @agencecoccinet,

    I have created a new WordPress 5.0.3 website and reinstall the plugin from scratch. I can import my campaigns and I can see it correctly with the use of the custom shortcode.

    I do not have any issue using this plugin.

    @agencecoccinet Would you kindly describe what is the issue you havee?

    I don’t think this plugin have any issue with WordPress 5.0.3 and will actually tag it as tested soon

    arjunmr

    (@arjunmr)

    Hi Matthieu

    Thanks for the update. I am on 5.0.3 and is definitely struggling. And my web project is in development from last 6 months and the plugin has been installed all this time. My question is – what is the best way to completely delete the plugin, reinstall it and try pulling the campaigns again. Because I have tried the normal – deactivate, delete, reinstall route a few times already and doesn’t work. I love the idea to start from scratch and would like to know, how best to go about it under my circumstances.

    On a side note – have you been able to modify the code to make it workable for WP 5x versions?

    Thanks!
    Arjun

    Plugin Author matthieuscarset

    (@matthieuscarset-1)

    Hi @arjunmr
    When you disable and delete the plugin form WordPress admin UI, there is already a function which delete all related data (so to say, options and imported Newsletters).

    Starting from scratch is therefore as easy as 1) disable and remove the plugin, 2) reinstall it and 3) reimport your campaigns.

    To answer your question, as I said right above :
    I’ve tested the plugin again on a fresh WordPress 5.x installation.
    Everything works as expected.
    I didn’t need to edit anything critical in code. Also, this plugin is already using Mailchimp API 3.0. So, nothing critical on this end neither.

    May I suggest you to open a new support thread to explain your issue?

    I think this current thread is resolved.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP 5 compliancy’ is closed to new replies.