Support » Alpha/Beta/RC » wp 5 beta multisite

  • Resolved carpconnect

    (@carpconnect)



    Hi, is multisite feature working in wp 5 beta3?

    Tried enabling in wp-settings.php but site won’t load after doing this?

    thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • JD

    (@mccroryj)

    Hello carpconnect,

    Yes, multisite works on all modern versions of WordPress, including beta.

    The easiest way that I enable WordPress is by using a Managed WordPress Host. They usually have a checkbox in the Control Panel that converts a Single Install to a MultiSite. It’s pretty cool! The same feature reverts MultiSites to Single Installs.

    Hope something I said I was helpful.

    Have a great day!

    • This reply was modified 1 week, 5 days ago by  Ipstenu (Mika Epstein). Reason: removed advert for host, removed signature
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    @mccroryj – Please don’t sign your posts (it’s against the guidelines) and please don’t put in a random advert for your web host of choice, it’s not at all on topic here.

    Multisite works fine on WP 5.0 betas. But what ‘wp-settings.php’ file are you editing? You’re supposed to edit wp-config.php

    Thanks for replies,

    i already have muiltisite (v4) running on server, but wanted to test out V5.

    wp-settings.php

    /**
     * Used to set up and fix common variables and include
     * the WordPress procedural and class library.
     *
     * Allows for some configuration in wp-config.php (see default-constants.php)
    
    // Initialize multisite if enabled.
    if ( is_multisite() ) {
    	require( ABSPATH . WPINC . '/class-wp-site-query.php' );
    	require( ABSPATH . WPINC . '/class-wp-network-query.php' );
    	require( ABSPATH . WPINC . '/ms-blogs.php' );
    	require( ABSPATH . WPINC . '/ms-settings.php' );
    } elseif ( ! defined( 'MULTISITE' ) ) {
    	define( 'MULTISITE', false );
    }

    So question is, does setting up multisite change in WP V5?

    Do just set this to ‘true’? or do you still need to edit wp-config.php and .htaccess files?

    thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Oh that’s not Multisite. Rather, that’s not NORMAL multisite. At all.

    https://codex.wordpress.org/Create_A_Network

    You never edit wp-settings.php for any of this. You just edit wp-config.

    I’m using Multisite and the 5.0 beta right now and it’s just peachy, so you’ve done something uniquely weird.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Marking resolved due to no reply in 5 days, and no one else can reproduce this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.