Support » Plugin: WP-Matomo Integration (WP-Piwik) » WP 5.7 support and PHP 7.3

  • Resolved blau

    (@blau)


    Hello and thank you for this plugin. I use a self hosted Piwik (now Matomo).

    I wonder if the plugin is fully working with wordpress 5.7 (hint: i guess it is, so far).

    Moreover, the plugin “wp php compatibility checker” raised this issues wit WP-Matomo Integration 1.0.24 and PHP 7.3 on my server. Do you have any comments?

    FILE: /var/www/mydomain.com/wp-content/plugins/wp-piwik/proxy/matomo.php
    ———————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————
    98 | ERROR | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ———————————————————————————————————

    FILE: /var/www/mydomain.com/wp-content/plugins/wp-piwik/classes/WP_Piwik.php
    ————————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————-
    385 | ERROR | Using ‘break’ outside of a loop or switch structure is invalid and will throw a fatal error since PHP 7.0
    ————————————————————————————————————————-

    Thank you again and best regards.

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WP 5.7 support and PHP 7.3’ is closed to new replies.