Support » Plugin: Enable jQuery Migrate Helper » WP 5.6 + Migration plugin doesn’t restore normal functioning

  • Resolved Themeover

    (@bastywebb)


    Hi there,

    I’m trying to figure out why enabling this plugin doesn’t completely fix issues with updating to WordPress 5.6. I’ve set the option to revert jQuery to 1.12.4, but some issues persist with the autocomplete jQueryUI widget that weren’t happening with WP 5.5.

    Do you know if WordPress 5.6 also makes some changes to jQueryUI? And if there is an equivalent migrate plugin that can buy me some time to work on a fix for my Microthemer plugin?

    Many thanks,
    Sebastian

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter Themeover

    (@bastywebb)

    I did a bit more digging and discovered that WP 5.6 includes a new jQuery UI library.

    WP 5.5 used jQueryUI version 1.11.4

    And now WP 5.6 uses jQueryUI version 1.12.1

    I’ve resorted to loading version 1.11.4 while I figure out how to fix the compatibility issues.

    I hope this info helps someone else. I didn’t come across any discussion of jQuery UI when reading about the jQuery changes in WP 5.6.

    Plugin Author Marius L. J.

    (@clorith)

    Hiya,

    Great catch, I must admit the jQuery UI library has not been a focus here, but there may be compatibility issues between it and jQuery if the versions do not match up properly.

    We’ll look into addressing that fairly rapidly, thanks for letting us know!

    @bastywebb could you share your method to load old jQueryUI? I’m having many little issues in admin screens.

    @ecommonist Change the JQuery version from “Default” to “Legacy 1.12.4-wp” in the setting page of the plugin.
    To be exact:

    Go to Tools > jQuery Migrate
    Set jQuery version to Legacy 1.12.4-wp
    Save settings

    • This reply was modified 10 months, 2 weeks ago by lucianogian.

    @lucianogian thank you, but it wasn’t that. I had code in functions.php conflicting with update and buttons in admin didn’t work properly. Now its commented and everything is fine again. Thank you guys!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP 5.6 + Migration plugin doesn’t restore normal functioning’ is closed to new replies.