Support » Plugin: WP-Matomo Integration (WP-Piwik) » WP 5.5: “Deprecated” message with Enable Jquery Migrate Helper

  • Resolved Bitpicker

    (@bitpicker)


    WP 5.5 is the first in a series of updates forcing out old and deprecated jquery code. While I don’t see any actual issues currently, this plugin causes the following message:

    wp-content/plugins/wp-piwik/js/jqplot/wp-piwik.jqplot.js: jQuery.support.boxModel is deprecated

    Might an update be expected? 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author braekling

    (@braekling)

    Thanks for the hint!

    I will provide an update later this week.

    @braekling
    The week is over and the message is still there. Will there be an update?

    Plugin Author braekling

    (@braekling)

    Update is available.

    Sadly, the used library (jqPlot) was not updated for a long time. There is a new version work in progress, but since 2018. For now, I just removed the deprecated code, because it was used to keep backward compatibility for Internet Explorer 8 and earlier, which is not necessary anymore, I hope.

    Next, I will look for a modern library to replace jqPlot. But the message should be gone with this. (I had to clear my cache once, btw.)

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.