Support » Plugin: Yoast SEO » WP 5.5 and latest Yoast not working together

  • Resolved scruffy1

    (@scruffy1)


    Hi

    Using WP 5.5 two sites one with standard blocks and the other with classic editor plugin, Yoast will not work on either site.

    All I can see on the post or page when editing are the 3 yoast tabs, ‘SEO, Readablity and Social’, nothing below them and the tab links do not work. Also in the right hand section the Yoast info for the post or page does not appear.

    So it suggests Yoast will not work with correctly WP5.5.

    Thanks Tracey

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hey there same for me.

    Is there any hotfix coming guys @yoast?

    I cannt edit anything with Yoast…Any fix?

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @scruffy1,

    Thanks for creating a new topic! You can disregard the other message.

    As you may know, some users have identified certain plugins or themes that conflict with the current version of Yoast SEO. To help us troubleshoot, we ask you to gather the following information for us:

    1. Can you confirm that all your other plugins and themes are up-to-date? If you’ve updated everything recently, can you make sure that you’ve cleared the cache from any page caching plugins and any server cache?

    2. Do any JavaScript errors appear in the browser console when you edit a page? If so, can you send us the error message or a link to a screenshot?

    3. Check for conflicts by deactivating all non-Yoast plugins and switching to a default WordPress theme like Twenty Nineteen. Does the error still appear?

    Same here, there is a plugin that WordPress theme has released with WP5.5 to enable jquery migrate which is perhaps the issue with this plugin. https://wordpress.org/plugins/enable-jquery-migrate-helper/ This should fix(for now) the issue. Hopefully all sorted with next update.

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @patrickwerzer,

    Thanks for the question and sorry to hear you’re having a similar issue.

    So far many issues we’re seeing have been due to conflicts with other plugins or themes, so this depends on whether this is due to a bug in Yoast SEO. We’re tracking confirmed bug reports in this GitHub repository if you’d like to check.

    If performing a conflict check and checking for JavaScript errors as mentioned above doesn’t identify the cause for your site, we recommend creating a new forum topic so that we can respond to you.

    Same issue. My yoast metabox is gone.

    Hi @priscillamc

    1) Yes other plugins and theme are up to date. Cache cleared and still same issue.

    2) NO JS errors

    3) We are unable to switch themes because they are both ‘live’ sites.

    Any other suggestions?

    Thanks Tracey

    omg same problem here… doesn’t work with “TinyMCE Advanced editor either” both ways it shows tab with nothing in it and unclickable.

    guys this worked for me and im quoting from another thread here

    https://wordpress.org/support/topic/wp-5-5-and-latest-yoast-not-working-together/

    Ivan

    (@denydz)

    16 minutes ago

    All you need to do is download and install the official WordPress plugin: Enable jQuery Migrate Helper

    (https://wordpress.org/plugins/enable-jquery-migrate-helper/)

    This is a temporary fix, until developers will fix their old line of codes.

    You can read more here.

    Plugin Support Jerlyn

    (@jerparx)

    @scruffy1 ,

    You can use the Health Check & Troubleshooting during the conflict check so your live site will not be affected. This step-by-step guide will show you what to do: https://yoast.com/help/how-to-check-for-plugin-conflicts/.

    When you find out the conflicting plugin, please let us know so we can investigate further.

    We look forward to your update.

    Plugin Support Jerlyn

    (@jerparx)

    @vegetarianzen @superangy123 ,

    We’re sorry you’re having the same issue. While running the Enable jQuery Migrate Helper plugin is a workaround for now, can you please also perform a conflict check to determine which plugin from your own setup is conflicting with Yoast SEO?

    Also, can you please create a new forum post here so we can easily track the issues? You will get your own alerts for the issue rather than someone else’s.

    Thank you. We look forward to your separate posts.

    Hi @jerparx,

    No conflicts in site health only this issue showing

    Error details: cURL error 28: Operation timed out after 5002 milliseconds with 0 bytes received (http_request_failed)

    What we have now done is reverted back to WP 5.4.2 because the live sites stopped income as soon as issues started so we could not take any further hits to income.

    Since reverting WP all now works. So this suggests the issue is either a conflict between Yoast and WP 5.5 or WP 5.5 is faulty and has been released too early.

    Thanks Tracey

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @scruffy1

    That cURL error shouldn’t cause any issues with regards to the information in the Yoast SEO meta box not loading. Just to confirm, even when enabling troubleshooting mode, having WP 5.5, enabling only a default theme such as TwentyTwenty and only the Yoast SEO plugin, the issue still occurred?

    Hi @mikes41720 ,

    OK.

    As stated in an earlier post, because the sites are live we cannot play around with changing themes, we are governed by our payment provider and changing anything that may be seen as experimental or affect customer security would mean we are in breach of contract.

    Anyway we reverted to WP 5.4.2 and all issues stopped.

    Thanks Tracey

    Plugin Support Carl B

    (@devnihil)

    @scruffy1 We understand if you are unable to perform any type of testing on the issue due to the site being live. If you don’t have a staging or development version of the site to test for conflicts, reverting to the previous version of WordPress to resolve this is a safer option until developers are able to releases updates for the issues being encountered with the 5.5 release.

    Updated today, WP 5.5, plugins, and themes. My media library wouldn’t show up. I deactivated all plugins and reactivated one by one, checking on the library after each. The Yoast plugin was the last one. When activated, the media library is blank. I have cleared the cache. Tried a different Chrome browser I used Yoast today before I found the problem. I will be ready to expect no media library with it is active, but will temporarily activate for a post.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.