Support » Plugin: Scripts n Styles » wp 5.4 – ( ! ) Deprecated: contextual_help

  • In WordPress 5.4+, when navigating to Posts -> All Posts, we got a deprecated warning (dev env).

    ( ! ) Deprecated: contextual_help está obsoleto desde a versão 3.3.0! Use get_current_screen()->add_help_tab(), get_current_screen()->remove_help_tab() em seu lugar. in ../www/…/wp-includes/functions.php on line 5088

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hi Guys,

    Yes, I get this error too. It started when I upgraded to PHP 7.4.

    As reported, the error code I receive (with WP_DEBUG_DISPLAY enabled) is:

    Deprecated: contextual_help is deprecated since version 3.3.0! Use get_current_screen()->add_help_tab(), get_current_screen()->remove_help_tab() instead. in …/wp-includes/functions.php on line 5148

    I get this code in the admin area on, for example Add New Page or Edit Page screens.

    The error message goes away when I disable the Scripts n Styles plugin, and returns when I re-enable it.

    I find a reference to “contextual_help” in your file class-sns-meta-box.php on line 99 and in class-sns-admin.php on line 134 (at least, and maybe in other of your plugin’s includes files; I haven’t checked them all.) When I comment out line 99 (Not sure what it does??) the error message goes away.

    I hope you’ll find time to fix that; the plugin still seems to be working otherwise, so it probably doesn’t need much to update it.

    Ref:
    https://developer.wordpress.org/reference/functions/add_contextual_help/
    https://developer.wordpress.org/reference/classes/wp_screen/add_help_tab/

Viewing 1 replies (of 1 total)
  • The topic ‘wp 5.4 – ( ! ) Deprecated: contextual_help’ is closed to new replies.