Support » Plugin: Polylang » WP 5.3 RC1 warning

  • Resolved leemon

    (@leemon)


    I’ve installed WP 5.3 RC1 and now Polylang throws a warning inside the Languages metabox in the classic editor:

    Declaration of PLL_Walker_Dropdown::walk($elements, $args = Array) should be compatible with Walker::walk($elements, $max_depth, ...$args) in /xxxxxxx/wp-content/plugins/polylang/include/walker-dropdown.php on line 94

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Chouby

    (@chouby)

    Hello,

    Thank you for testing Polylang with WP 5.3 RC1.

    We are aware of this warning. Unfortunately, there is no way to remove it without dropping the support of PHP < 5.6 which we plan to do in Polylang 2.7 but not in Polylang 2.6.x.

    The warning has no consequence on Polylang functionalities.

    The development version of Polylang 2.7 already removes it. See: https://github.com/polylang/polylang/issues/414 and https://make.wordpress.org/core/2019/10/09/wp-5-3-introducing-the-spread-operator/ for the background on what change in WP introduced the warning.

    For users seeing the warning on production site, set WP_DEBUG to false in wp-config.php and it will not be displayed anymore.

    Buenos días,

    A mi me ha dado este error y ha dejado de funcionar la biblioteca de medios, (cuando cargas imágenes y cuando visualizas la biblioteca de medios en modo rejilla) no carga las imágenes se queda eternamente cargando, y si subes una nueva te da error y te dice pruebe mas tarde, aunque si vas a la biblioteca de medios en listado si que aparece.
    He desactivado polylang y ya me funciona.

    Sabeis si tiene solución?

    • This reply was modified 2 months, 2 weeks ago by evasonder.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.