Support » Fixing WordPress » WP 5.3 Post Upgrade Issue: I get a blank screen trying to edit/add a post/page

  • Resolved freem33

    (@freem33)


    Hi,

    My issue seems to be with Google Chrome, as it works ok in firefox.

    I followed your instructions for diagnosing javascript errors. This is what I get when trying to work in chrome:

    Uncaught TypeError: Cannot read property core-data.min.js?ver=2.7.4:1
    ‘transientEdits’ of undefined
    at core-data.min.js?ver=2.7.4:1
    at f (core-data.min.js?ver=2.7.4:1)
    at Ut (core-data.min.js?ver=2.7.4:1)
    at data.min.js?ver=4.9.2:1
    at Object.r [as hasEditsForEntityRecord] (data.min.js?ver=4.9.2:1)
    at editor.min.js?ver=9.7.5:11
    at e (data.min.js?ver=4.9.2:1)
    at data.min.js?ver=4.9.2:1
    at Object.r [as isEditedPostDirty] (data.min.js?ver=4.9.2:1)
    at wds-editor.js:48
    core-data.min.js?ver=2.7.4:1 Uncaught TypeError: Cannot read property ‘transientEdits’ of undefined
    at core-data.min.js?ver=2.7.4:1
    at f (core-data.min.js?ver=2.7.4:1)
    at Ut (core-data.min.js?ver=2.7.4:1)
    at data.min.js?ver=4.9.2:1
    at Object.r [as hasEditsForEntityRecord] (data.min.js?ver=4.9.2:1)
    at editor.min.js?ver=9.7.5:11
    at e (data.min.js?ver=4.9.2:1)
    at data.min.js?ver=4.9.2:1
    at Object.r [as isEditedPostDirty] (data.min.js?ver=4.9.2:1)
    at EventTarget.is_post_dirty (wds-editor.js:104)

    So what’s my next move?

    Thanks for the help,

    Mark

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Oh… I skipped Step 2 because I don’t recall how to find the wp-config.php file…

    Moderator t-p

    (@t-p)

    My issue seems to be with Google Chrome…

    Try disabling browser extensions.

    I don’t recall how to find the wp-config.php file

    – It should be in the WP root directory unless it was moved a directory up.

    freem33

    (@freem33)

    Hi t-p,

    OK,

    I disabled browser extensions (via Google Chrome Advanced Settings – Restore Settings)

    No change

    I added the debug command as per step 2 of the javascript troubleshooting…

    No change

    The problem still exists.

    Please advise of next steps / Thanks,

    Mark

    Moderator t-p

    (@t-p)

    Please review this thread and try troubleshooting steps listed therein.

    shaunmehr

    (@shaunmehr)

    @freem33 you may want to try installing Disable Gutenberg plugin. That fixed the issue for me.

    Disable gutenberg fixed it for me too.

    Hello @freem33 ,

    1st @gutenberg is a great editor for me. So here is my tip for you instead of disabling Gutenberg.

    If you use a security plugin like WP Hide & Security Enhancer, you may need to set the “REST API” options to “NO”. AS I LEARNED FROM THE AUTHOR ON THIS TOPIC, DO NOT BLOCK THE REST API ACCESS BY ANY PLUGIN.

    By the way, I have the same issue and waiting for a fix from the plugin author. Click here to see my request.

    Good Luck!

    Thanks to everyone who has weighed in!

    Yup… Disabling Gutenberg has resolved the problem. I did not try disabling all my other plug-ins or switch my theme – I am trying to run a website here…

    I hope some folks are working on the issue so we can return to Gutenberg at some point

    Mark

    Hi There!

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    It’s not certain that this is a Gutenberg bug, it’s more likely a bug in a plugin extending the editor or loading scripts in the editor.

    Thanks

    Moderator t-p

    (@t-p)

    I hope some folks are working on the issue so we can return to Gutenberg at some point

    Couple of days ago, Gutenberg released a new version 6.9.0, which is compatible with WP 5.3

    Update if haven’t already.

    I work on Gutenberg and I can say that we didn’t fix any issue related to this thread because we don’t know yet if there’s an issue in the Editor itself or plugins. We can’t reproduce our selves so far.

    The error is thrown by the SmartCrawl SEO plugin from WPMUDev

    hook_change_listener() {
    			let debounced = _.debounce(() => this.dispatch_content_change_event(), 10000);
    
    			wp.data.subscribe(() => {
    				if (
    					this.get_editor().isEditedPostDirty()
    					&& !this.get_editor().isAutosavingPost()
    					&& !this.get_editor().isSavingPost()
    				) {
    					debounced();
    				}
    			});
    		}

    Line 48 is this.get_editor().isEditedPostDirty()

    And later line 104 is the return statement here

    is_post_dirty() {
    		return this.get_editor().isEditedPostDirty();
    	}

    Thanks everyone for your input / help…

    After working on my site for a week with the old editor, I re-installed Gutenberg and disabled Smartcrawl and I’m now able to edit my posts / pages!

    Thanks Christoph!

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.